Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Noob problem with Gallery

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 3538 Views
  • bones
    Avatar
    Community Member
    104 Posts

    Noob problem with Gallery Link to this post

    Hello

    I only started using Silverstripe about a week ago, and it's gone pretty smoothly so far, so I'm astonished (and somewhat embarrased) that I can't figure out how to use the gallery module.

    I've followed the documentation, installed it, got all of the tabs and things up and running, but just don't seem to be able to do the final bit.

    I've..

    - Added an extension, selected filetype and uploaded a default icon
    - Ticked the extension in the list, and pressed "save"
    - Selected the folder to show the images from, under the "files" tab

    Erm.. then what?

    All help gratefully recieved.

    Thanks

    John-Lee

  • stooni
    Avatar
    Community Member
    89 Posts

    Re: Noob problem with Gallery Link to this post

    Testing with IE perhaps is going i think is a ticket open, the other way you upload Files via a php fileuploader and then you must set chmod 777 , in the silverstripe you must go to files and first view the files in sst filemanager, then you can see and put in your site in the browser!!!

    i hope these will help!!

    ---- Stooni

  • bones
    Avatar
    Community Member
    104 Posts

    Re: Noob problem with Gallery Link to this post

    Thanks, stooni.

    I've uploaded the pictures, but how do I actually get the Gallery onto the page?

    John-Lee

  • stooni
    Avatar
    Community Member
    89 Posts

    Re: Noob problem with Gallery Link to this post

    Open in the sst the filemanager and view are the files are there???

    then you can get in the sst site , you must have installed the http://www.silverstripe.com/modules/ Gallery (v0.2.2)
    1. dont forget the /db/build/?flush=1 and the /?flush=1
    then you become a folder for the Gallery put the pictures in there and create a Gallery Site in the sst!!!

    ---Stooni

  • bones
    Avatar
    Community Member
    104 Posts

    Re: Noob problem with Gallery Link to this post

    Hi stooni

    Yes, I can see the images in the "files & images" tab.

    I select the Extension and click save.

    When I go back to my GalleryPage, and click on the "files" tab, I select the folder that the images are in.

    I've attached screen grabs.

    I'm very grateful to you for your help and patience.

    Kind regards

    John-Lee

  • stooni
    Avatar
    Community Member
    89 Posts

    Re: Noob problem with Gallery Link to this post

    Fine in the Tab Extensions on the gallery Site klicking the first --- png,jpg,jpeg,gif.. perhaps delete your created extension Save all und View your Gallery!!! I think its now going these point is at my site these way..

    I hope it's goning now!!!

    Thanks -------stooni

  • bones
    Avatar
    Community Member
    104 Posts

    Re: Noob problem with Gallery Link to this post

    Nope.

    It just doesn't want to work

  • stooni
    Avatar
    Community Member
    89 Posts

    Re: Noob problem with Gallery Link to this post

    Please upload Screenshot from Site Gallery and Registercard Gallery perhaps here is something wrong!!!

    ---Stooni---

    3538 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.