Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Uploads 'first uploaded' 37 years ago

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 2926 Views
  • henno
    Avatar
    Community Member
    6 Posts

    Uploads 'first uploaded' 37 years ago Link to this post

    Fresh install of v2.0.1

    All of my uploads are not populating the date they were uploaded.

    i.e. the details are as follows:

    Filename
    URLassets/products/image.jpg
    TypeJPEG Image - good for photos
    Size34 KB
    Owner
    Dimensions200x300
    First uploaded01/01/1970, 37 years ago
    Last changed24/04/2007, 3 days ago

    As you can see, the 'Last Changed' date works fine, but the 'First uploaded' date is obviously not being populated in the database correctly at the point of upload.

    I haven't researched any further than merely reproducing the error.

    henno.

  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: Uploads 'first uploaded' 37 years ago Link to this post

    I've noticed this thing in the past but didn't deem it severe enough to be fixed; I'll ensure it gets on our to-fix list

    The error is fairly understandable... 1/1/1970 is the "beginning" of time for PHP in most situations, if you're wondering why that particular date is being shown

  • henno
    Avatar
    Community Member
    6 Posts

    Re: Uploads 'first uploaded' 37 years ago Link to this post

    Yeah I realise where the date comes from. Just not sure why it is not being populated.

    You're right, it is no big deal, and in fact, I just uploaded some PDFs (as opposed to the GIFs I was uploading before) and it seems they are adopting the correct date, so who knows.

    henno.

  • Jedateach
    Avatar
    Forum Moderator
    227 Posts

    Re: Uploads 'first uploaded' 37 years ago Link to this post

    It looks like this bug occurs in specific circumstances. I'm looking into it.

    So far I've been able to add both jpg and gif images with the associated first uploaded date being correct.

    Let me know if you find out what these circumstances are. ;)

  • marc
    Avatar
    Community Member
    2 Posts

    Re: Uploads 'first uploaded' 37 years ago Link to this post

    Hi!
    It appears when I do some changes (like changing title) and then save.

  • spark
    Avatar
    Community Member
    15 Posts

    Re: Uploads 'first uploaded' 37 years ago Link to this post

    Any more info on this? I see the same problem when I update any article on my site. It changes the date to 12.31.1969. Please send any help!

    Thanks,
    Danielle

    2926 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.