Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » <hr /> turning into <hr >

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1786 Views
  • a-tech
    Avatar
    Community Member
    39 Posts

    <hr /> turning into <hr > Link to this post

    Hey guys, hope you can help here.

    When i put an <hr /> into my SS templates, the HR wont show in the browser and looking at code shows it as <hr >.

    Is this something I have done?

  • a-tech
    Avatar
    Community Member
    39 Posts

    Re: <hr /> turning into <hr > Link to this post

    Same thing happens when I put an <hr> into my content via admin.

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: <hr /> turning into <hr > Link to this post

    Is this the output of placing the <hr> directly in the template itself, using $Content in your template, or using modifiers like $Content.Summary, or $Content.FirstParagraph?

    I don't recall ever having a problem generating <hr> tags...

    Cheers,
    Sean

  • Matt
    Avatar
    Core Development Team
    84 Posts

    Re: <hr /> turning into <hr > Link to this post

    It's probably the content negotiation - XHTML will not be sent as XHTML unless you specify the <?xml header as well as a correct XHTML doctype.

    Something about IE being annoying when you send it XML when it's not expecting it.

    1786 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.