Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » extremely slow loading backend and very slow/delayed text editor

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 8050 Views
  • milan
    Avatar
    Community Member
    3 Posts

    extremely slow loading backend and very slow/delayed text editor Link to this post

    Hi,

    It looks like I am not the only person here experiencing the following problems:

    1) slow loading backend. When I log in it takes up to 1 minute until the backend is loaded. I am experiencing this with both my own website and your online demo, with both IE 7 and Firefox 2. I can see in the download progress bar of both browsers that single items/pictures/etc. are loaded one by one, extremely slowly...

    2) text editor is slow too. When I write, there is a delay and I have to wait until the editor catches up with my writing...

    I really hope somebody can help with fixing these issues as the system itself looks very nice but this slowness just renders it useless for my clients.

    Regards,
    Milan

  • Willr
    Avatar
    Forum Moderator
    5462 Posts

    Re: extremely slow loading backend and very slow/delayed text editor Link to this post

    The next major version of SilverStripe (2.3) has alot of speed improvements, in the mean time try using Firefox 3 which I have found to be way more responsive with the JS in the backend.

    But saying that demo seems to work quite quick for me.

  • milan
    Avatar
    Community Member
    3 Posts

    Re: extremely slow loading backend and very slow/delayed text editor Link to this post

    Ok, so backend loading should be faster then..? How about the editor? All other editors I tried so far work fast (Typo3, Joomla etc.) but the Silverstripe-editor has that annoying delay which makes entering textes very uncomfortable...

    Kind regards,
    Milan

  • Willr
    Avatar
    Forum Moderator
    5462 Posts

    Re: extremely slow loading backend and very slow/delayed text editor Link to this post

    Ok, so backend loading should be faster then..? How about the editor? All other editors I tried so far work fast

    Are you tryin SilverStripe on a local server? Try if on a local server and see how it responses, this will see if its something about your browser setup (any plugins that you have, old versions etc) or if it could be a slow internet connection?.

  • milan
    Avatar
    Community Member
    3 Posts

    Re: extremely slow loading backend and very slow/delayed text editor Link to this post

    I have Typo3-Websites and this one Silverstripe-Website on the same server. It's a virtual dedicated server hosted with Godaddy.
    The Typo3-websites load fast, no speed/performance problems at all. Only the Silverstripe-installation is painfully slow...

    Kind regards,
    Milan

  • Ingo
    Avatar
    Forum Moderator
    801 Posts

    Re: extremely slow loading backend and very slow/delayed text editor Link to this post

    > When I write, there is a delay and I have to wait until the editor catches up with my writing...

    thats pretty extreme - what CPU/RAM are you running on? especially considering that typo3 loads myriads of assets if uncached, and uses an equally heavy HTMLArea plugin by default (we use TinyMCE), its suprising that it should be much faster.

  • m191
    Avatar
    Community Member
    1 Post

    Re: extremely slow loading backend and very slow/delayed text editor Link to this post

    The perfomance issue with SilverStripe is a deal breaker for me. Hopefully version 2.3 will be improved and will revisit this promising CMS when it becomes available.

    It has a great user interface for content editors. I shouldn't have to ask end users to change their browser. Nor should I have to tweak my default server settings for a modest implementation of SilverStripe.

    I have used various apps: MODx, CMSMS, Typolight, eZ Publish, even Joomla (ugh!), all with no performance issues . . .

  • TF
    Avatar
    Community Member
    10 Posts

    Re: extremely slow loading backend and very slow/delayed text editor Link to this post

    I have the same problem with a SilverStripe installation.

    It all works fine for me, but the people I installed it for are complaining about the load time. They are on a 512/512kbit connection, which should be sufficient in my opinion.

    I will try installing Firefox 3 on their computer tomorrow. Any other suggestions?

    Any idea about how long to Silverstripe 2.3?

    8050 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.