Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Audio on the Gallery causes error

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1943 Views
  • throb
    Avatar
    Community Member
    23 Posts

    Audio on the Gallery causes error Link to this post

    Howdy,
    I just got into SS today. It seems like the answer to my CMS prayers.
    I installed the Gallery and got images going. Lightbox isn't working but I am sure I can deal with that. However, I am getting an error (server in debug) that i will paste here.
    I am not sure what's wrong. The page does display correctly after the giant error log here and the link to the mp3 does work.

    What am I doing wrong?
    thanks for your help in advance
    rob

    FATAL ERROR: filesize() [function.filesize]: stat failed for /Users/throb/Sites/silverstripe/gallery/images/Default.gif
    At line 306 in /Users/throb/Sites/silverstripe/cms/code/GalleryPage.php

    filesize(/Users/throb/Sites/silverstripe/gallery/images/Default.gif)
    line 306 of GalleryPage.php

    GalleryPage->GalleryItems(0,5)
    line 385 of GalleryPage.php

    GalleryPage->CurrentGalleryItems()

    call_user_func_array(Array,Array)
    line 177 of Object.php

    Object->__call(CurrentGalleryItems,Array)

    GalleryPage_Controller->CurrentGalleryItems()

    call_user_func_array(Array,Array)
    line 542 of ViewableData.php

    ViewableData->cachedCall(CurrentGalleryItems,,)
    line 583 of ViewableData.php

    ViewableData->hasValue(CurrentGalleryItems)
    line 198 of .cache.Users.throb.Sites.silverstripe.cms.templates.Layout.GalleryPage.ss

    include(/private/var/folders/b3/b34kFibJFnu6KIe4dSqDzk+++TI/-Tmp-/silverstripe-cache-Users-throb-Sites-silverstripe/.cache.Users.throb.Sites.silverstripe.cms.templates.Layout.GalleryPage.ss)
    line 197 of SSViewer.php

    SSViewer->process(GalleryPage_Controller)
    line 189 of SSViewer.php

    SSViewer->process(GalleryPage_Controller)
    line 296 of Controller.php

    Controller->defaultAction(index,Array)
    line 267 of Controller.php

    Controller->run(Array)
    line 22 of ModelAsController.php

    ModelAsController->run(Array)
    line 104 of Director.php

    Director::direct(/music)
    line 158 of main.php
    Context
    Debug (Debug::showError() in line 180 of Debug.php)

    * limit =

    0,5

    * items =
    dataobject set
    o
    Database record: File
    + ID :

    24

    + ClassName :

    File

    + Created :

    1969-12-31 00:00:00

    + LastEdited :

    2008-07-06 15:12:27

    + Name :

    03-Altered-From-Catechization.mp3

    + Title :

    Goat Pig

    + Content :

    + ParentID :

    21

    + Filename :

    assets/galleries/Music/03-Altered-From-Catechization.mp3

    + RecordClassName :

    File

    + PopupWidth :

    0

    + PopupHeight :

    0

    + Embed :

    0

    + LimitDimensions :

    0

    + ViewLink :

    http://localhost:8888/silverstripe/assets/galleries/Music/03-Altered-From-Catechization.mp3

    + HasDimensions :

    1

    + PopupDimensions :

    1

    + Width :

    500

    + Height :

    500

    * cpt =

    1

    * item =
    Database record: File
    o ID :

    24

    o ClassName :

    File

    o Created :

    1969-12-31 00:00:00

    o LastEdited :

    2008-07-06 15:12:27

    o Name :

    03-Altered-From-Catechization.mp3

    o Title :

    Goat Pig

    o Content :

    o ParentID :

    21

    o Filename :

    assets/galleries/Music/03-Altered-From-Catechization.mp3

    o RecordClassName :

    File

    o PopupWidth :

    0

    o PopupHeight :

    0

    o Embed :

    0

    o LimitDimensions :

    0

    o ViewLink :

    http://localhost:8888/silverstripe/assets/galleries/Music/03-Altered-From-Catechization.mp3

    o HasDimensions :

    1

    o PopupDimensions :

    1

    o Width :

    500

    o Height :

    500

    * ext =

    mp3

    * extensions =
    ComponentSet
    o Type: many-to-many
    o Size: 1
    * extension =
    Database record: GalleryPage_Extension
    o ID :

    2

    o GalleryPageID :

    7

    o GalleryPage_ExtensionID :

    2

    o ClassName :

    GalleryPage_Extension

    o Created :

    2008-07-06 11:03:49

    o LastEdited :

    2008-07-06 11:03:49

    o Title :

    Sounds

    o Extensions :

    wav, mp3, ram, m4a, mp4, wma

    o Type :

    ImagesSoundsVideos

    o LimitDimensions :

    0

    o GalleryIconID :

    0

    o RecordClassName :

    GalleryPage_Extension

    * group =
    Database record: GalleryPage_Extension
    o ID :

    2

    o GalleryPageID :

    7

    o GalleryPage_ExtensionID :

    2

    o ClassName :

    GalleryPage_Extension

    o Created :

    2008-07-06 11:03:49

    o LastEdited :

    2008-07-06 11:03:49

    o Title :

    Sounds

    o Extensions :

    wav, mp3, ram, m4a, mp4, wma

    o Type :

    ImagesSoundsVideos

    o LimitDimensions :

    0

    o GalleryIconID :

    0

    o RecordClassName :

    GalleryPage_Extension

    * params =

    lightwindow_width=500,lightwindow_height=500

    * icon =
    Database record: Image
    o ID :

    0

    o IdentityURL :

    * segment =

    gallery/images/Default.gif

    * absolute =

    /Users/throb/Sites/silverstripe/gallery/images/Default.gif

  • throb
    Avatar
    Community Member
    23 Posts

    Re: Audio on the Gallery causes error Link to this post

    i just checked and it does this for .mov files as well.
    i am not sure what's going on.
    rob

  • Sam
    Avatar
    Administrator
    679 Posts

    Re: Audio on the Gallery causes error Link to this post

    It's having trouble reading the file gallery/images/Default.gif

    * Check that it exists. If not, re-install the gallery module
    * Check that it's readable by the webserver. If not, make it readable.

  • throb
    Avatar
    Community Member
    23 Posts

    Re: Audio on the Gallery causes error Link to this post

    thanks, sam.

    i deleted the SS install dir and reinstalled from scratch. that seemed to sort it.

    now i want to add a better mp3 player to the list of music :

    http://www.1pixelout.net/code/audio-player-wordpress-plugin/

    that would be smashing! i can't find the area that specifically detects for the .mp3, etc extension or else i would try to fix/break the code

    rob

  • spark
    Avatar
    Community Member
    15 Posts

    Re: Audio on the Gallery causes error Link to this post

    HELP!

    My postings for news articles are setting the date as this: 1969-12-31

    Can you tell me why or help me find a solution? Thanks!

  • spark
    Avatar
    Community Member
    15 Posts

    Re: Audio on the Gallery causes error Link to this post

    Can anyone please help me with this problem... My dates are showing as 12/31/1969 but they are not from 1969! They show up on my events pages this way. ANy help would be greatly appreciated.

    1943 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.