Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » installation problem - "there are two ... files with the same filename"

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 3823 Views
  • vovabigov
    Avatar
    Community Member
    4 Posts

    installation problem - "there are two ... files with the same filename" Link to this post

    During installation server prints out 3 errors. It goes like this:

    "
    I am now running through the installation steps (this should take about 30 seconds)

    If you receive a fatal error, refresh this page to continue the installation

    Creating 'mysite/_config.php'...
    Creating /home/a7244252/public_html/mysite/_config.php
    Creating '.htaccess' file...
    Creating /home/a7244252/public_html/.htaccess
    Building database schema...
    PHP Error Message

    Notice: Warning: there are two 'Extension' files with the same filename: '/home/a7244252/public_html/sapphire/core/Extension.php' and '/home/a7244252/public_html/auth_openid/code/Auth/OpenID/Extension.php'. This might mean that the wrong code is being used. in /home/a7244252/public_html/sapphire/core/ManifestBuilder.php on line 256

    Notice: Warning: there are two 'XML' files with the same filename: '/home/a7244252/public_html/sapphire/integration/XML.php' and '/home/a7244252/public_html/auth_openid/code/Auth/Yadis/XML.php'. This might mean that the wrong code is being used. in /home/a7244252/public_html/sapphire/core/ManifestBuilder.php on line 256

    Fatal error: Class 'Extension' not found in /home/a7244252/public_html/sapphire/core/model/DataObjectDecorator.php on line 16
    "

    What does it mean?

  • Willr
    Avatar
    Forum Moderator
    5464 Posts

    Re: installation problem - "there are two ... files with the same filename" Link to this post

    it means pretty much what is says - Notice: Warning: there are two 'XML' files with the same filename. - Theres 2 files with the same name and since SS standard is 1 class per file and the name of the file must be the same as the class its probably complaining about 2 XML class's.

    You using 2.2.2 or the latest trunk / dailybuild version?

  • vovabigov
    Avatar
    Community Member
    4 Posts

    Re: installation problem - "there are two ... files with the same filename" Link to this post

    Thanx for help. The problem is still actual.

    I'm using 2.2.2 ver.

    So, what should I do? - delete files or what?

    I just simply downloaded last stable version and tried to install it - should I search for some older version?

    PS: and there is another tipe of error:

    "Class 'Extension' not found "

    should I try to find out php bag by myself or there is some ready solve for this?

  • rbquirke
    Avatar
    Community Member
    70 Posts

    Re: installation problem - "there are two ... files with the same filename" Link to this post

    I replicated the issue in two different environments from the 2.2.2 release downloaded from:
    http://www.silverstripe.co.nz/assets/downloads/PHPInstaller/silverstripe-v2.2.2.tar.gz

    I have just downloaded the CVS version and the installation ran perfectly.

    There is clearly an issue with the gzipped release which is surprising given it has a release date of May 2008.

    It may well be that it is an environment specific issue but that would surprise me as I attempted installation on both my local (WAMP) environment and dev server (Linux system running Apache).

    If anyone needs more details, let me know.

  • rbquirke
    Avatar
    Community Member
    70 Posts

    Re: installation problem - "there are two ... files with the same filename" Link to this post

    Ho hum...

    Well after checking some more, it looks like there isn't any issue with the code.

    I had unpacked the gzipped tar on my Windows pc using IzArc and then uploaded to my linux box, also used the same code to try installation on my local machine. Obviously the extraction caused some file corruption or some other spanner in the works.

    After unpacking the file directly on my linux environment, the installation worked a charm.

    vovabigov: I would suggest you have a similar issue.

  • vovabigov
    Avatar
    Community Member
    4 Posts

    Re: installation problem - "there are two ... files with the same filename" Link to this post

    >>I had unpacked the gzipped tar on my Windows pc using IzArc and then uploaded to my linux box, also used the same code to try installation on my local machine. Obviously the extraction caused some file corruption or some other spanner in the works.

    After unpacking the file directly on my linux environment, the installation worked a charm.

    vovabigov: I would suggest you have a similar issue.
    <<

    Yep! I had unpacked the gzipped tar on my Windows pc using IzArc too.

    I'll try to unpack on server and ll'let U know.

  • vovabigov
    Avatar
    Community Member
    4 Posts

    Re: installation problem - "there are two ... files with the same filename" Link to this post

    So, I can not unpack files on server because my hosting don't let start command "system" on server.

    And while I unpack dsitributive under Windows, Windows corrupt them.

  • rbquirke
    Avatar
    Community Member
    70 Posts

    Re: installation problem - "there are two ... files with the same filename" Link to this post

    try using winrar on Windows.

    As for linux, if you can ssh in to your hosting, run the following command:
    tar -zxvf silverstripe-v2.2.2.tar.gz

    (or whatever the release file is called)

    3823 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.