Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Install: "XML Parsing Error: junk after document element"

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1616 Views
  • Jorgen
    Avatar
    Community Member
    3 Posts

    Install: "XML Parsing Error: junk after document element" Link to this post

    Have attempted installing SS v2.0.1 and a couple of nightly builds. Each lead to the same basic problem, which is: an XML Parsing Error. Specifically:

    XML Parsing Error: junk after document element
    Location: http://www.mydomain.com/home/successfullyinstalled
    Line Number 2, Column 1:<b>Notice</b>: Undefined index: trace in <b>/var/www/vhosts/mydomain.com/httpdocs/sapphire/main.php</b> on line <b>19</b><br />

    I am running on a Plesk VPS environment, RH Fedora 4, PHP 5. When installing using the nightly builds I receive no mod_rewrite or AllowOverride error (e.g. rewritetest.php) it doesn't pop, but on the v2.0.1 version, I receive the mod_rewrite error check each time with the "proceed anyway" option.

    However, using either version, I end up with the XML Parse error above when trying to access the site following install.

    I have done various tests on .htaccess (redirect to google, etc.) that seem to prove it is working as advertised. Guessing I have about tried every combination of httpd.conf and vhosts.conf mod I can think of for AllowOverrides. I believe, on a VPS, the vhosts.conf overrides httpd.conf for the domain in question, but I'm not 100% certain.

    I have tried AllowOverrides in the most generic sense (in httpd.conf) for any Directory or all the way down to httpdocs. In the vhost.conf, I've specified the path. I am fairly certain the vhosts.conf is being picked up, because for another CMS trial I needed open_basedir set to 'none' and using vhosts worked like a charm.

    Anyway, from non-SS related searches, this seems to have some ties to .htaccess, but I'm not sure specifically what. I haven't seen or read any specific errors for this in regard to SS, so any thoughts / help would be appreciated. I'll keep trial / error'ing away until I get it working.

    Thanks,
    Jorgen

  • Andy
    Avatar
    230 Posts

    Re: Install: "XML Parsing Error: junk after document element" Link to this post

    This is due to SilverStripe not being fully PHP_NOTICE safe yet. Settin error_reporting to E_ALL ^ E_NOTICE in your php.ini should solve this.

  • Jorgen
    Avatar
    Community Member
    3 Posts

    Re: Install: "XML Parsing Error: junk after document element" Link to this post

    Yes ... ironic, I was just about to try again and this fixed it. Whew. Thought I'd tried about everything else and didn't even occur to change the php.ini error settings.

    Now, onto the fun part.

    Jorgen

    1616 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.