Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » 'next' and 'back' buttons not working when browsing through newsletter members

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 2107 Views
  • Decisive Flow
    Avatar
    Community Member
    73 Posts

    'next' and 'back' buttons not working when browsing through newsletter members Link to this post

    If we have more than 10 newsletter subscribers, we can no longer view any but the first page. This used to work and I am wondering if it broke during the updates yesterday? - we didnt have more than 10 in dev so missed it (back and next buttons broken)

    Also the 'filter' functions has results:

    Element.replace('Form_EditForm_Recipients','
    \n
    \n
    Search

    which I assume is also broken.

  • Simon
    Avatar
    Core Development Team
    27 Posts

    Re: 'next' and 'back' buttons not working when browsing through newsletter members Link to this post

    Ah, the latest version of SS had some cunning bugs regarding the way we encoded javascript to be evaluated after a AJAX request.

    The behaviour on the button was not using the AJAX evaluator, and was encoding it twice, thus causing the new line problem.

    The other bug was just the response not being encoded correctly.

    These are all fixed it the latest release.

    Cheers,
    Simon

    2107 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.