Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Files and Images upload problem 'fix'

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1017 Views
  • Pixel
    Avatar
    Community Member
    78 Posts

    Files and Images upload problem 'fix' Link to this post

    Hey SSers,
    Im not sure if this is a great 'fix' - whether its a security problem or is just wrong, fullstop.

    When I put a site live or transfer the site from a test domain to the live domain I always seem to get one of two problems with the Files and Images tab.
    Either:
    1. The files upload but they do not re-sample
    or
    2. Uploading files results in an error + you cant create new folders

    The folders within the assets folder are 755 and the user is ftp-username and group is pascln

    So...

    The way I 'fix' this is by setting the permissions on the assets folder as 777.
    You can then create new folders that then have the permissions of 775 by default and have its user and group set to www-data.
    Files can now be uploaded, thumbnails created and images inserted and displaying on the site.

    Does this work with other people? Is it a security problem as I, to be honest, don't really know my permissions and what they do, along with my php ability ; )

    What do you think?

    1017 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.