Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Can't add HomePage.php in Tutorial 1

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 792 Views
  • biokrome
    Avatar
    Community Member
    2 Posts

    Can't add HomePage.php in Tutorial 1 Link to this post

    I've seen others with this issue but have not seen a resolution, though I may have missed it.

    I've installed WAMP on WinXP and installed SS as per instructions. I started going through Tutorial 1 and all was well (after modifying the URL to remove ':3000') until I got to the part about changing the home page.

    I put HomePage.php in \tutorial\code and flushed the db. The page shows this:

    FATAL ERROR: Bad class to singleton() - HomePage
    At line 85 in C:\wamp\www\silverstripe-empty\sapphire\core\Core.php

    user_error(Bad class to singleton() - HomePage,256)
    line 85 of Core.php

    singleton(HomePage)
    line 175 of DatabaseAdmin.php

    DatabaseAdmin->doBuild()
    line 90 of DatabaseAdmin.php

    DatabaseAdmin->build(Array)
    line 261 of Controller.php

    Controller->run(Array)
    line 104 of Director.php

    Director::direct(/db/build)
    line 158 of main.php

    followed by some other stuff. Needless to say the new HomePage type was not added to Admin.

    So, how exactly do I change the home page?

    Thanks

    792 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.