Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Poor response times - slow speed

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 3423 Views
  • Pottsy
    Avatar
    Community Member
    19 Posts

    Poor response times - slow speed Link to this post

    Hi

    I have a site www.imageslasertek.co.nz which I am well down the track of developing for a customer.

    He is complaining the response times can be very slow ie over 60 seconds and more to load each new page. The speeds can vary from being adequate to excessively slow and I am unbale to tell whether this is due to internet speed issues, server load problems or simply silverstripe is dragging its heels loading the pages.

    The server is a linux based server.

    I have found reference to xcache as a solution which I am investigating further. Can someone please suggest some ideas of how to improve the response times.

    Many thanks

  • Blackdog
    Avatar
    Community Member
    156 Posts

    Re: Poor response times - slow speed Link to this post

    have you setup the silverstripe-cache folder?

  • Pottsy
    Avatar
    Community Member
    19 Posts

    Re: Poor response times - slow speed Link to this post

    I have the silverstripe-cache folder created and it appears to be being used by the system

  • Blackdog
    Avatar
    Community Member
    156 Posts

    Re: Poor response times - slow speed Link to this post

    well it isn't slow here.

    I am getting 2-3 second page loads.

  • Pottsy
    Avatar
    Community Member
    19 Posts

    Re: Poor response times - slow speed Link to this post

    Hmmmmm.

    I am suspecting the problem is ISP related, but am having difficulty proving it to be able to satisfy my customer who is best descibed as technologically challenged. Trying to explain to him things like ISP, server performance, Silverstripe performance and the difference between them is very challenging to get him to understand.

    Thanks for your input. I would appreciate anyones comments and where they are and their ISP should they be interested.

    Many thanks

  • Ingo
    Avatar
    Forum Moderator
    801 Posts

    Re: Poor response times - slow speed Link to this post

    XCache generally improves script performance in SilverStripe by an order of 2x to 5x from our experience, so its definetly worth pursuing. As for testing the performance, have you heard of "ab" tool (Apache Benchmark)?

  • Pottsy
    Avatar
    Community Member
    19 Posts

    Re: Poor response times - slow speed Link to this post

    No

    Where should I look for it?

    Cheers Neil

  • Double-A-Ron
    Avatar
    Community Member
    604 Posts

    Re: Poor response times - slow speed Link to this post

    I have loaded the site 6 times with the following speeds given to me by Yslow:

    (seconds)
    3.4 - first load
    1.9
    1.8
    1.4
    1.2
    1.3

    I don't see an issue on the SS/Server side of things. I think your client's complaints are connection based if they are reporting up to a minute load times.

    I think your time is better spent addressing that first, as no mods you make to the site will seem reasonable to the client if the rest of us are already seeing reasonable response times.

    Surely they have similar delays loading most sites if it is their ISP. If not, it may be a DNS issue with thier ISP or manual DNS settings.

    I'm in NZ, and our ISP is Horizon.

    Cheers
    Aaron

    3423 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.