Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Stuck on login page???

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 3552 Views
  • rjh
    Avatar
    Community Member
    5 Posts

    Stuck on login page??? Link to this post

    I've read the bug fixes that address the issue of modifying the _config.php file and the .htaccess file, but installation still leaves me stuck on the "loading page".
    I should say it leaves me on the loading page when viewed in FireFox,
    it simply resets the login form in IE....?

    I'm stumped since I've tried every possible thing I can think of to fix it.

  • xmedeko
    Avatar
    Community Member
    94 Posts

    Re: Stuck on login page??? Link to this post

    Post here your _config.php and .htaccess, please.

  • rjh
    Avatar
    Community Member
    5 Posts

    Re: Stuck on login page??? Link to this post

    <<.htaccess>>

    ### SILVERSTRIPE START ###
    RewriteEngine On

    RewriteRule \.js$ - [L]
    RewriteRule \.css$ - [L]
    RewriteRule \.png$ - [L]
    RewriteRule \.jpg$ - [L]
    RewriteRule \.gif$ - [L]
    RewriteRule \.php$ - [L]

    RewriteCond %{REQUEST_URI} ^(.*)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule .* /home/build33/public_html/highexodus/sapphire/main.php?url=%1&%{QUERY_STRING} [L]
    ### SILVERSTRIPE END ###

    <<_config.php>>

    <?

    global $project;
    $project = 'mysite';
    Security::setDefaultAdmin('admin','password');

    global $databaseConfig;
    $databaseConfig = array(
    "type" => "MySQLDatabase",
    "server" => "localhost",
    "username" => "build33_xxxxxxxx",
    "password" => "xxxxxxxx",
    "database" => "build33_xxxxxx",
    );

    ?>

  • rjh
    Avatar
    Community Member
    5 Posts

    Re: Stuck on login page??? Link to this post

    I'm trying to install on a sub-domain, so I think that might be the source of my problems...?

  • xmedeko
    Avatar
    Community Member
    94 Posts

    Re: Stuck on login page??? Link to this post

    Are you accessing SS by http://server/~build33/ ?
    I have also problem installing SS into my home directory /home/xmedeko and access it by http://server/~xmedeko. I was not trying to fix it, though.

  • rjh
    Avatar
    Community Member
    5 Posts

    Re: Stuck on login page??? Link to this post

    Yes,
    I am trying to access SS through my default hosting path /build33/public_html/
    and I'm trying to install to a sub-domain folder called highexodus, but
    for some reason the login will not work.

  • xmedeko
    Avatar
    Community Member
    94 Posts

    Re: Stuck on login page??? Link to this post

    try to change last few lines in .htaccess from:

    RewriteCond %{REQUEST_URI} ^(.*)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule .* /home/build33/public_html/highexodus/sapphire/main.php?url=%1&%{QUERY_STRING} [L]

    to:

    RewriteBase /~build33/highexodus
    RewriteCond %{REQUEST_FILENAME} !-f^
    RewriteRule (.*) sapphire/main.php?url=$1 [L,QSA]

    Note the %1 has changed to $1

  • rjh
    Avatar
    Community Member
    5 Posts

    Re: Stuck on login page??? Link to this post

    okay,
    I made the changes to the .htaccess page you suggested
    and now I get the following parsing error:

    Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/build33/public_html/highexodus/sapphire/core/ManifestBuilder.php on line 18

    3552 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.