Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » User Of Security Group Keeps Getting Logged Out Of Admin

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1535 Views
  • Liam
    Avatar
    Community Member
    470 Posts

    User Of Security Group Keeps Getting Logged Out Of Admin Link to this post

    I setup a security group for content editors. I gave them certain permissions as seen in the attached screenshot.

    When a user logs in, they are brought to the admin section. As soon as they click on another page, a dialogue box pops up saying they have been logged out of the admin area, and they are directed back to the login form.

    These are just basic pages. I also noticed that pages that have images associated with them with an ImageField, they can't view them. When they click on the tab, it says they don't have permission to view it, and a login form appears in that iframe.

  • Liam
    Avatar
    Community Member
    470 Posts

    Re: User Of Security Group Keeps Getting Logged Out Of Admin Link to this post

    Here is the images tab when logged in with this group. That iframe is saying I don't have permission to access this feature in the whole front end template which doesn't fit in the frame.

    If I grant full administrative permission to the group, then there is no problem. I've tested this on 2 sites I've built, and same thing.

    I have the proper permissions for viewing the assets area it seems, and there is no other complex logic in any of the page types. Not sure why it keeps logging me out after one page view.

  • mikewheaton
    Avatar
    Community Member
    9 Posts

    Re: User Of Security Group Keeps Getting Logged Out Of Admin Link to this post

    I'm having a similar problem with users with limited permissions being constantly logged out. The only documentation I could find is at http://doc.silverstripe.com/doku.php?id=permissions:codes and it's not terribly helpful.

  • banal
    Avatar
    Community Member
    901 Posts

    Re: User Of Security Group Keeps Getting Logged Out Of Admin Link to this post

    I encountered the same problem and submitted a bug-report for it. A possible solution can be found in the bug-report (somebody submitted a patch already): http://open.silverstripe.com/ticket/2769

    Edit Just for clarity: The mentioned bug-report addresses the issue with permissions on iframes for file-uploads.

  • Liam
    Avatar
    Community Member
    470 Posts

    Re: User Of Security Group Keeps Getting Logged Out Of Admin Link to this post

    Perfect.

    That's what was causing the issue of logging out since all the page types are the same, and have the image field iframe.

    I just used your quick fix for now, as that works good enough.

    Glad this will be resolved in the next release.

    Thanks.

    1535 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.