Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » _resampled folder ist not created - images in CMS do not work at all

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1607 Views
  • freakout
    Avatar
    Community Member
    49 Posts

    _resampled folder ist not created - images in CMS do not work at all Link to this post

    i've read some similar posts but none of the solutions have helped.
    when i upload images and try to use them in the CMS all links are broken
    and pointing to _resampled folder which does not exist:

    [Sun Oct 26 18:49:09 2008] [error] [client 217.231.250.42] File does not exist: /home/wirt/site/assets/images/_resampled/StripThumbnail-silverstripe1.gif
    [Sun Oct 26 18:51:10 2008] [error] [client 217.231.250.42] File does not exist: /home/wirt/site/assets/images/_resampled/ResizedImage10075-15minutes.gif

    when i create the folder manually with 775 in every assets folder which contain
    images nothing changes. only when i erase the width/height tags and the
    _resampled/ResizedImagennn stuff with the HTML editor of the CMS the
    images are shown and published correct.

    im running php as cgi with rights of user/group of the complete tree of
    the silverstripe installation - the rest of the system is running fine. this
    image problem is the only trouble i have so far.

  • Willr
    Avatar
    Forum Moderator
    5482 Posts

    Re: _resampled folder ist not created - images in CMS do not work at all Link to this post

    Have you tried creating the folder yourself and giving 777 rights to the folder?

  • freakout
    Avatar
    Community Member
    49 Posts

    Re: _resampled folder ist not created - images in CMS do not work at all Link to this post

    Yes created folder with 777 - no image is created in this folder but page references it.
    I made another installation with running php as apache module. On this platform i
    have not this issue - interesting is that it doesn't create _resampled folder and images
    on this platform at all! It uses ?r=36034 appended to the image .gif url.

    sizew.freakout.de - - [26/Oct/2008:21:02:13 +0100] "/home/tsselb/silvers/assets/images/15minutes.gif" "GET /assets/images/15minutes.gif?r=36034 HTTP/1.1" 200 5981

    I can not see thumbnails on this platform - and have apache 404 for them in the log:

    sizew.freakout.de - - [26/Oct/2008:21:01:58 +0100] "/home/tsselb/silvers/assets/images/_resampled" "GET /assets/images/_resampled/StripThumbnail-riscmon.jpg?r=32926 HTTP/1.1" 404 322

  • Apophenian
    Avatar
    Community Member
    46 Posts

    Re: _resampled folder ist not created - images in CMS do not work at all Link to this post

    Were you able to resolve this problem? I am having the same issue...

  • Apophenian
    Avatar
    Community Member
    46 Posts

    Re: _resampled folder ist not created - images in CMS do not work at all Link to this post

    haha

    As it turns out, gd wasn't enabled on the clients webserver. Oops...

    1607 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.