Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » installation problem in Ubuntu

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1384 Views
  • speedooo
    Avatar
    Community Member
    11 Posts

    installation problem in Ubuntu Link to this post

    Hi,

    who said it's easy install.....
    I installed Apache2+php5+remoteMySQL
    test successful by phpmyadmin and phpinfo page.
    after install/extract silverstripe under /var/www/
    I tried to install silverstripe2.2.2
    1. install.php
    I changed it to accept my remote mySQL config, all good.
    install php-gd for gd2 support.
    changed permission for .htaccess file and mysite, turorial , assets folder.
    All good alowed me to clieck "Install SilverStripe" button.

    2. got message like,
    . Creating 'mysite/_config.php'
    . Creating /var/www/silverstripe/mysite/_config.php
    . Crating '.htaccess' file
    . creating /var/www/silcerstripe/.htaccess
    . Building database schema...
    . Checking mod_rewrite works http://......
    . Creating /var/www/silverstripwe/.htaccess http://localhost/silverstripe/installerTest/testrewrite
    . Error: mod_rewrite not working, redirecting to mod_rewrite test page

    very quickly redirect to /rewritetest.php

    3. then I got
    Warning: file_get_contents(http://localhost/silverstripe/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /var/www/silverstripe/rewritetest.php on line 47

    Warning: file_get_contents(http://localhost/silverstripe/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /var/www/silverstripe/rewritetest.php on line 47
    mod_rewrite doesn't appear to be working. Make sure:

    * mod_rewrite is enabled in your httpd.conf
    * AllowOverride is enabled for the current path.

    Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway.

    4. after I click here to proceed anyway.
    I got NOT FOUND page in http://localhost/silverstripe/home/successfullyinstalled?flush=1

    Apache/2.2.8 (Ubuntu) Phusion_Passenger/1.0.5 PHP/5.2.4-2ubuntu5.3 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g Server at localhost Port 80

    anything wrong i my process, how could i test my mod_rewrite is working?

    thanks

  • speedooo
    Avatar
    Community Member
    11 Posts

    Re: installation problem in Ubuntu Link to this post

    I installed the latest version 2.2.3, problem gone. thanks.
    God knows what's wrong!!

    1384 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.