Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » SilverStripe HATES Windows MySQL

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1251 Views
  • Axonn
    Avatar
    Community Member
    6 Posts

    SilverStripe HATES Windows MySQL Link to this post

    Hi everybody ::- D. My first post here. An unfortunate one, unfortunately ::- D.

    I am trying to install SilverStripe on a Windows machine, with MySQL 5. And this is the error I get at install NO MATTER WHAT I DO.

    That username/password doesn't work: Access denied for user 'SYSTEM'@'localhost' (using password: NO)

    I DO NOT tell it "System". I use the root username with THE CORRECT password. I also tried OTHER usernames, same error. It keeps complaining about SYSTEM, SYSTEM, SYSTEM, arghhhhhhhh, it's driving me CRAZY!!!!!!!

    Again, I repeat, I give it the correct password and everything. I also tried setting MySQL to accept 4.0 compatible security, NOTHING.

    Some messages end with "please help, I'm desperate".

    I will end with PLEASE HELP OR I'LL KILL MYSELF. Ok, I'm joking ::- ). But really, I'm at the limit of my imagination in solving this issue ::- (.

  • Nivanka
    Avatar
    Community Member
    395 Posts

    Re: SilverStripe HATES Windows MySQL Link to this post

    Are you running on WAMP?

    I have installed SilverStripe on wamp with out any problem at all, sometime it might be a problem with the mysql host address.

  • Axonn
    Avatar
    Community Member
    6 Posts

    Re: SilverStripe HATES Windows MySQL Link to this post

    Does the server exist ----->   OK (localhost)

    I used it with standard mysql.

    Then I dumped that, and switched to XAMPP.

    Same problem. It's a problem SilverStripe has with MySQL. I don't see why I MUST use WAMP. It's just a program pack, it should work with my configuration too. By the way, I installed SilverStripe today on a Linux server, I provided the correct credentials and same problem.

    EDIT:

    Damn ::- ( ... this isn't a SilverStripe problem so I apologize. But maybe somebody can still help. I run a PHP website on that machine AND IT WORKS, but for other SQL connections it does not work and I do not understand why. I get the same SYSTEM@ error even for this simple PHP code:

    <?php
    $dbConn;
    $active;
    $database;
    $dbConn = mysql_connect('localhost', 'ffoll', 'testt');
          $active = mysql_select_db('funfoll', $dbConn);
          $database = 'funfoll';
          if(!$dbConn) {
             die("Couldn't connect to MySQL database");
          }
    ?>

  • Hamish
    Avatar
    Community Member
    712 Posts

    Re: SilverStripe HATES Windows MySQL Link to this post

    Might be your MySQL setup - do you know how to read the my.conf file? Post it here if you can.

  • Nivanka
    Avatar
    Community Member
    395 Posts

    Re: SilverStripe HATES Windows MySQL Link to this post

    Also check whether the localhost is open for that user.

    1251 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.