Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Javascript error after enabling multi language

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 2889 Views
  • antonio.volpon
    Avatar
    Community Member
    8 Posts

    Javascript error after enabling multi language Link to this post

    Hello.

    I'm using the latest version of Silverstripe and I enablen in _conf.php the multilanguage support. I recreated tables and found the new label "translations".

    However, when i try to add a new language I receive a "Javascript parse error" in red near the bottom of the admin page. I tried it in Firefox and Chrome and both shows the same error.

    Did i forget anything?

    Thanks,
    Antonio

  • SImoX
    Avatar
    Community Member
    11 Posts

    Re: Javascript error after enabling multi language Link to this post

    I resolved partially the problem going in CMSMain.php (into CMS folder) and changing

    FormResponse::add("$('Form_AddPageOptionsForm').getElementsByTagName('div')[1].getElementsByTagName('input')[0].disabled=true;");

    into

    FormResponse::add("$('Form_AddPageOptionsForm').getElementsByTagName('div')[2].getElementsByTagName('input')[0].disabled=true;");

    and

    FormResponse::add("$('Form_AddPageOptionsForm').getElementsByTagName('div')[1].getElementsByTagName('input')[0].disabled=false;");

    into

    FormResponse::add("$('Form_AddPageOptionsForm').getElementsByTagName('div')[2].getElementsByTagName('input')[0].disabled=false;");

    (in my file at rows 1293 and 1299). Let me know. bye

    2889 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.