Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Installation problem, i'm go crazy

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1669 Views
  • Luca
    Avatar
    Community Member
    8 Posts

    Installation problem, i'm go crazy Link to this post

    Hi to all community, this is my first post.

    Yesterday i download SS and i try to install it on my virtual server (ubuntu 6.06), but i have a problem with the installation. All system requirements is OK (all are green) but when the installation start i get the error:

    ERROR: mod_rewrite not working, redirecting to mod_rewrite test page.

    Also, the browser go to the other page where i have 4 warning like:

    Warning: file_get_contents () [function.file-get-contents]; php_network_getaddress: getaddrinfo failed: Temporary failure in name resolution ... on line 47

    Can anybody help me please? I wan't to use SS for all my sites, but if i can't install it....

    Thanks in advance!
    Luca from italy.

  • Luca
    Avatar
    Community Member
    8 Posts

    Re: Installation problem, i'm go crazy Link to this post

    I can say in add that i install SS in this folder /var/www/firstsite.
    My apache2 conf point to /var/www but in the browser i point to <ip address>/firstsite/install.php. I think that is the correct way to install.

    Thanks to all.
    Luca

  • Nuttydo
    Avatar
    Community Member
    16 Posts

    Re: Installation problem, i'm go crazy Link to this post

    It could be that your sever is PHP4 and not PHP5 and that mod_rewrite is switched off. You need to switch it on. If you have a virtual server then you have no direct access to the server files. You must put commands in your web server that changes the settings so that PHP5 is loaded and mod_rewrite is 'enabled'

    First thing to check: Is the server PHP 4 or 5? You need PHP 5.
    Create a Get.php file to see what version you are using. Use this code:

    <?php

    phpinfo();

    ?>
    and call the file getinfo.php

    If you see that PHP 5 is already ON the server, then stop reading now. I can't help you!

    But...

    If the file says PHP 4 then you need a '.htaccess' file which tells it to load PHP 5 (ask your provider for the code). Then try and install again. Here is the code I used, no guarantee it will work for you:
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    If it still doesn't work, then you need to enable mod_rewrite. Ask your provider for the code. From my provider I got this code which I put into the folder where all of my SilverStripe files are. Here is the code my provider gave me (just as an example, it may not work for you):

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    RewriteEngine on
    RewriteCond % index/(.*)\.html$
    RewriteRule index/(.*)\.html$ /index.php?kategorie=$1

    Check the getinfo file again. Check for the command 'allow_url_fopen' in the PHP. This should be 'on' in PHP5. If it is 'off', then you need a php.ini file to switch it on. Put it in the folder where the main SilverStripe folders are.

    Then wait a while for the server to update itself. This doesn't happen immediately.

    I hope this can help.

  • Luca
    Avatar
    Community Member
    8 Posts

    Re: Installation problem, i'm go crazy Link to this post

    Thanks Nuttydo.....
    Unfortunately i have php5 (version 5.1.2) installed... I have mod_rewrite installed and work fine. I think is a DNS problem, or i don't know...

    When i run from command line rewritetest.php i get this error:
    Warning: file_get_contents(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/firstsite/rewritetest.php on line 47

    Warning: file_get_contents(http://./InstallerTest/testrewrite): failed to open stream: Connection refused in /var/www/firstsite/rewritetest.php on line 47

    Warning: file_get_contents(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/firstsite/rewritetest.php on line 47

    Warning: file_get_contents(http://./InstallerTest/testrewrite): failed to open stream: Connection refused in /var/www/firstsite/rewritetest.php on line 47
    mod_rewrite doesn't appear to be working.

    But i'm sure that module work correctly...

    Could be a problem on how apache2 is configured? The server run on my local pc (virtualized by vmware..)... ?

  • jam13
    Avatar
    121 Posts

    Re: Installation problem, i'm go crazy Link to this post

    Sounds like a DNS problem to me. Two things to check:

    1) Can you can resolve names from the shell (e.g. ping www.google.com)

    2) Is your hosts file set up properly - you need your IP address and hostname in there otherwise apache can be a bit funny.

  • Luca
    Avatar
    Community Member
    8 Posts

    Re: Installation problem, i'm go crazy Link to this post

    Thanks jam...
    After some configuration issue (in vmware player) the error chenge in this:

    "failed to open stream HTTP request failed! ... 404 NOT FOUND..."

    In fact the rewritetest try to open <my domain>/firstsite/InstallerTest/testrewrite...

    But on my server this folder does not exists... Why it try to open this folder that not exists?

    1669 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.