Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » forum errors Controller.php

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1921 Views
  • itlinux
    Avatar
    Community Member
    40 Posts

    forum errors Controller.php Link to this post

    Notice: Controller::currentController() is deprecated. Use Controller::curr() instead. in /home/httpd/vhosts/controlmanager5.com/silverstripe-v2.2.3/sapphire/core/control/Controller.php on line 367

    any suggestions on this? If I update the forum to the svn it does not give me this error but the the forum does not take the permission anymore so there is a few bugs going on. Apache 2x or Centos 5.2. php-mysql-5.2.6-jason.1
    php-mcrypt-5.2.6-jason.1
    php-pear-db-1.7.13-2.el5.rf
    php-5.2.6-jason.1
    php-xml-5.2.6-jason.1
    php-odbc-5.2.6-jason.1
    php-ncurses-5.2.6-jason.1
    php-pear-MDB2-Driver-mysql-1.4.1-3.el5.centos
    php-common-5.2.6-jason.1
    php-cli-5.2.6-jason.1
    php-soap-5.2.6-jason.1
    php-xmlrpc-5.2.6-jason.1
    php-ldap-5.2.6-jason.1
    php-pecl-Fileinfo-1.0.4-3.el5.centos
    php-pdo-5.2.6-jason.1
    php-devel-5.2.6-jason.1
    php-imap-5.2.6-jason.1
    php-gd-5.2.6-jason.1
    php-pecl-memcache-2.2.3-1.el5_2
    php-pear-Log-1.9.13-1.el5.centos
    php-pear-1.6.2-1.jason.1
    php-dba-5.2.6-jason.1
    php-pear-MDB2-2.4.1-2.el5.centos
    php-mbstring-5.2.6-jason.1
    php-mhash-5.2.6-jason.1

    Thanks. Remo

  • Willr
    Avatar
    Forum Moderator
    5511 Posts

    Re: forum errors Controller.php Link to this post

    This is probably because you are using an old version of forum with a newer version of SilverStripe. Check out a recent dailybuild of the forum, It should be slightly more stable / usable on newer SS versions and have a few little improvements

  • itlinux
    Avatar
    Community Member
    40 Posts

    Re: forum errors Controller.php Link to this post

    if I use the newest version pull yesterday I cannot get an error that as soon as I change the permission to allow everyone to view the forum it crashes. Any suggestions on that?

    Thanks,
    Remo

    1921 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.