Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » IIS 7 Installation Error please help

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1785 Views
  • AndrewMK
    Avatar
    Community Member
    23 Posts

    IIS 7 Installation Error please help Link to this post

    Hi, I am just trying to install silver stripe so we can evaluate it as a potential CMS for our organisation and I have run into the following error:

    PHP Notice: Undefined index: SERVER_SIGNATURE in
    C:\inetpub\wwwroot\silverstripe\install.php on line 159 PHP Notice: Undefined index:
    SERVER_SIGNATURE in C:\inetpub\wwwroot\silverstripe\install.php on line 510

    I am running this on Windows server 2008 with IIS 7.0 and mysql.
    I created a phpinfo page and can confirm i do not have the server_signature variable and i cannot work out hoew to get it?

  • AndrewMK
    Avatar
    Community Member
    23 Posts

    Re: IIS 7 Installation Error please help Link to this post

    I fixed this error by altering install.php to use SERVER_SOFTWARE instead of SERVER_SIGNATURE.

    Now i seem to be having issues on the actual install.
    I run the install and after a while I get the below error:

    PHP Notice: Undefined index: type in
    C:\inetpub\wwwroot\silverstripe\sapphire\security\Security.php on line 654

    Can anyone help with this error?

    1785 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.