Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Ampersand breaks the rss feed.

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 2301 Views
  • ScottiouS
    Avatar
    Community Member
    54 Posts

    Ampersand breaks the rss feed. Link to this post

    After taking a while to figure out why my rss feed was not displaying in Firefox I found that it was not validating because of an ampersand ( & ) in the title of an article.

    It would be really good if the CMS either changed ampersands to & or did something with this. I find that if I do try to put in an & it doesn't convert to an ampersand either, the only solution is to type and. Also have the same problems with quote marks in titles causing the system to fall over when viewing that article.

    I'm sure that this has been mentioned elsewhere but I could not find anything about how it related to the RSS falling over.

  • Ingo
    Avatar
    Forum Moderator
    801 Posts

    Re: Ampersand breaks the rss feed. Link to this post

    just run it through Converter.php, by outputting $Title.XML rather than $Title in your *.ss-template

  • Markus
    Avatar
    Google Summer of Code Hacker
    152 Posts

    Re: Ampersand breaks the rss feed. Link to this post

    I fixed that in GSoC r39702.. you should merge that into trunk

    2301 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.