Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Database corrupt!

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1703 Views
  • poblom
    Avatar
    Community Member
    25 Posts

    Database corrupt! Link to this post

    Our site has been running live now for a couple of month. Suddenly tonight the site is down with "The website server has not been able to respond to your request."

    Put it in dev-mode and got a lot of nasty errors telling me that the database had to be repaired.

    Guess I would have to run /db/build?flush=1, but how can I do that without beeing able to login??

    Need some help!

    /PO

  • Nivanka
    Avatar
    Community Member
    395 Posts

    Re: Database corrupt! Link to this post

    does it tell you which table is corrupted?

    I had the same problem once with an ExpressionEngine website and all I had to do is to repair the table which has got errors.

    Try with this reference:

    http://dev.mysql.com/doc/refman/5.1/en/repair-table.html

    but f you have a phpmyadmin installed it will be much easier for you to do that.

  • poblom
    Avatar
    Community Member
    25 Posts

    Re: Database corrupt! Link to this post

    Thanks Nivanka!

    Problem solved!

    SiteTree was damaged. Managed to do a "REPAIR TABLE" from phpmyadmin and the site is up and running again. (www.hasselbladfoundation.org)

    /PO

  • Nivanka
    Avatar
    Community Member
    395 Posts

    Re: Database corrupt! Link to this post

    Nice one!

    1703 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.