Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Installing SilverStripe on Windows Vista and IIS Services

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 2670 Views
  • Mike Adkins
    Avatar
    Community Member
    1 Post

    Installing SilverStripe on Windows Vista and IIS Services Link to this post

    I am in need of a good CMS system that I can use as a development platform for work.

    I need to first get the environment platform working on my develpment machine before migrating it to one of my servers running IIS.
    The servers are running Windows Server 2003 Professional. My office development machine is running Windows XP Professional and my
    development laptop is running Windows Vista.

    For now I do most of my develpment work and testing on my Vista laptop so that is my starting point.

    I hope to document the process and try to make it over the obsticals as I go. So this is the first obstical.

    I have downloaded FastCGI to host PHP Applcations on IIS 7.0
    I am running IIS Version 7.0 SP1 on my Vista Laptop.
    I have installed the Update for Windows Vista (KB954946).
    I have modified the php.ini per the installation instructions.

    Now for the first problem. WHen setting up the Handler Mappings FastCgiModule is not available in the Module: dropdown box.
    Should I select CGI instead? This does not seem to allow PHP to run under IIS.

    2670 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.