Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » The new Gallery Module

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2 3 4
Go to End
Author Topic: 20979 Views
  • ulysses
    Avatar
    Community Member
    57 Posts

    Re: The new Gallery Module Link to this post

    Hi - You have viewd my page after I got this problem resolved. The XML parsing error was due to to missing <tr> tag in the generated HTML when you only have 2 pictures. With just one picture it displays it correctly, but add a second or third one, it fails to create the <tr> tag when starting the second image section. Anyway, when I entered about 5 or so, it worked fine.

    Hope this helps someone with a similar problem.

    Thanks.

  • saimo
    Avatar
    Community Member
    67 Posts

    Re: The new Gallery Module Link to this post

    Actually, I have the same problem, but with six items which are not images due to end-user misuse. It's still a bug though, which should get resolved somehow. My theory about the problem is that it is FirstItemLine that fails to return true when the current item is the first of a row. So, I tried to look at the code, but I can't find the definition. Where is it?

    http://sbmk.nu/motiontelefonlistor/

  • ulysses
    Avatar
    Community Member
    57 Posts

    Re: The new Gallery Module Link to this post

    This has already been logged as a bug.

  • saimo
    Avatar
    Community Member
    67 Posts

    Re: The new Gallery Module Link to this post

    Ok, I should have checked that.

    20979 Views
Page: 1 2 3 4
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.