Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Installation frustration

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1275 Views
  • poohbear
    Avatar
    1 Post

    Installation frustration Link to this post

    Have spent the better part of the last day trying to get silverstripe to install I’m inclined to go back to Mambo. I have limited technical knowledge and having failed to find any decent documentation on the steps involved in installing silverstripe am totally lost. The hosting company have assured me that the problems I’m encountering are related to silverstripe and since mambo installed without any problems I’m inclined to agree. I hope that someone can help…

    I continuously receive the error: open_basedir restriction in effect

    I don’t have the knowledge or tools to implement the many hacks I have found within the forums to work around this problem and it seems to me that a product which differentiates itself from the rest in user friendliness shouldn’t require such crude interventions. Help!

  • Sam
    Avatar
    Administrator
    679 Posts

    Re: Installation frustration Link to this post

    I think that smoother installation/operation under safe-mode is something that we should put a priority on in our next release.

    Andrew - would you be able to switch your development environment to run in safe mode, so that we can more actively deal with these issues as they arise?

    poohbear - we'll make a announcement on the site when these safe-mode issues have been resolved.

  • Willr
    Avatar
    Forum Moderator
    5508 Posts

    Re: Installation frustration Link to this post

    me and andy had this problem installing gguymotors.co.nz last night as well. I think safe mode is a pretty common problem so getting it fixed is important. poohbear try sames tip - removing lines 38-44 of main.php - the stuff about envFiles. That seems to fix my problems.

  • Andy
    Avatar
    230 Posts

    Re: Installation frustration Link to this post

    I'm now running using safe mode and open_basedir. I've fixed all the errors I've found so far, they should be in the daily builds tonight. I'll look into the installer later.

    1275 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.