Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » adding a page type, a couple of questions....

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 2329 Views
  • Nicolaas
    Avatar
    Forum Moderator
    213 Posts

    Re: adding a page type, a couple of questions.... Link to this post

    Hmmm, that is very funny!

    The draft site works fine, but the real site does not work! I am getting the following error:

    FATAL ERROR: None of these templates can be found: SiteTree.ss, DataObject.ss<br />
    At line 53 in /home/winsboroughconz/www/sapphire/core/SSViewer.php<br />

    The cms is in perfect order.

    I did delete all the php files in my code page, and thus, for a moment, the pages did not have the right template files available (I rebuilt the database).

    Then I put everything back in.

    I just checked my CMS, everything is in perfect order.

    Hmmm, I going to reinstall from scratch I think.

    Thanks for all your help

    Nicolaas

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: adding a page type, a couple of questions.... Link to this post

    A less drastic measure would be just dropping the database, and rebuilding it (providing you don't need any of the data in it).

    Cheers,
    Sean

  • Nicolaas
    Avatar
    Forum Moderator
    213 Posts

    Re: adding a page type, a couple of questions.... Link to this post

    OMG,

    I just worked out what is going on.

    Firstly, yes, you get an error if a page is of a template style that no longer exists and you rebuild the database. However, you can rectify this by changing the template in the CMS. No sweat there. Luckily it does not cause a meltdown.

    What I did is that I added icons to the pages in the CMS. That works nice, because you can immediately see what type of page it is. However, what I noticed is that you can not see the status of the page anymore (e.g. draft, published, etc...). So I did not realise that the pages had not been published yet. A quick "publishAll" did wonders!

    Thanks again for all your help. Now I have to find out how I can show the status of the page. Or perhaps I am thinking about just adding a publishAll button.

    Cheers

    Nicolaas

    2329 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.