Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » SilverStripe 2.1.0-rc1

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2 3
Go to End
Author Topic: 46480 Views
  • Andy
    Avatar
    230 Posts

    SilverStripe 2.1.0-rc1 Link to this post

    Announcing SilverStripe 2.1.0-rc1, the first release candidate leading up to the 2.1.0 release. It contains the following notable changes:

    - Theme support
    - Widget support
    - Better extension API
    - Unit testing framework
    - Comment administration section, and comment moderation
    - TinyMCE has been updated to 2.1.1.1

    For a full list of changes see the ChangeLog. Documentation for these features will be provided before the final 2.1.0 release, which will coincide with the release of the new blog module. You can download SilverStripe 2.1.0-rc1 from the following location:
    http://www.silverstripe.com/assets/rc/silverstripe-v2.1.0-rc1.tar.gz

    Please test and provide feedback so we can make 2.1.0 nice and stable!

    Thanks!

  • Willr
    Avatar
    Forum Moderator
    5502 Posts

    Re: SilverStripe 2.1.0-rc1 Link to this post

    Yay!!

  • mandrew
    Avatar
    Core Development Team
    32 Posts

    Re: SilverStripe 2.1.0-rc1 Link to this post

    It's like all my Christmas' have come at once! Cheers to all that have put in so much work releasing this!

  • pr0ph3t
    Avatar
    4 Posts

    Re: SilverStripe 2.1.0-rc1 Link to this post

    first error

    Installing SilverStripe...

    I am now running through the installation steps (this should take about 30 seconds)

    If you receive a fatal error, refresh this page to continue the installation
    # Creating 'mysite/_config.php'...
    # Creating '.htaccess' file...
    # Building database schema...
    # Checking mod_rewrite works
    # ERROR: mod_rewrite not working, redirecting to mod_rewrite test page
    I will now try and direct you to rewritetest to troubleshoot mod_rewrite

    there its stuck...

    and this is what i get after installation failure,,,

    FATAL ERROR: None of these templates can be found: Page.ss, ContentController.ss
    At line 67 in C:\wamp\www\silverstripe-v2.1.0-rc1\sapphire\core\SSViewer.php

    testing done using latest version of WAMP with rewrite_module enabled and working with other CMSes...

    cheers, hopefully you help me out maybe i do something wrong coz i'm new to Silverstriper

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: SilverStripe 2.1.0-rc1 Link to this post

    pr0ph3t: Are you installing onto a completely new database, or overwriting an old one?

    Cheers,
    Sean

  • pr0ph3t
    Avatar
    4 Posts

    Re: SilverStripe 2.1.0-rc1 Link to this post

    me and matt (from your team) figured out what was the problem on IRC, ?flush=1 solved the issue. Database and installation was totally new.

    imho
    the theme engine you added needs to be updated for overall API during install

    the
    mysite/_config.php

    SSViewer::set_theme('blackcandy');

    line was not automatically updated thus page.ss and rest of files could not be found in themes directory where they suppose to be according to new SS structure

    but i could be wrong i'm only few days with SS,,, thanks to packtpub.com's survey

  • dio5
    Avatar
    Community Member
    501 Posts

    Re: SilverStripe 2.1.0-rc1 Link to this post

    Installed and seems to work for me. The save & publish is a nice improvement.

    The access tab seems to be what I need, but unfortunately in 'security groups' you can't set group member permissions for sections of the frontend - as suggested in http://doc.silverstripe.com/doku.php?id=permissions:codes.
    It would be nice if we could set this on certain id's and include subpages as well.

    So I guess this access-tab is for people who can login into the backend only?
    I think this would be much more useful if this would allow us to control 'frontend' users as well.

  • Cifro
    Avatar
    Community Member
    2 Posts

    Re: SilverStripe 2.1.0-rc1 Link to this post

    During new installation a i got this error:

    ...
    Building database schema...

    Fatal error: DATABASE ERROR: Couldn't run query: insert into `SiteTree_versions` SET `ShowInMenus` = '0', `ShowInSearch` = '0', `Status` = '', `Viewers` = 'Anyone', `Editors` = 'LoggedInUsers', `Title` = '', `Content` = '', `URLSegment` = '', `LastEdited` = '', `Created` = '2007-09-14 17:56:41', `ClassName` = 'SiteTree', `MenuTitle` = '', `MetaTitle` = '', `MetaDescription` = '', `MetaKeywords` = '', `HomepageForDomain` = '', `ProvideComments` = '0', `Sort` = '0', `LegacyURL` = '', `HasBrokenFile` = '0', `HasBrokenLink` = '0', `ReportClass` = '', `ViewersGroup` = '0', `EditorsGroup` = '0', `ParentID` = '0', `Version` = 1, `RecordID` = 1, `AuthorID` = 0 | Incorrect datetime value: '' for column 'LastEdited' at row 1 in E:\internet\apps\silverstripe-v2.1.0-rc1\sapphire\core\model\Database.php on line 368

    Environment is:
    WinXP/Apache 2.2.4/PHP 5.2.3/MySQL 5.0.45-community-nt

    46480 Views
Page: 1 2 3
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.