Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Fatal error on Gallery install

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1631 Views
  • nascent
    Avatar
    6 Posts

    Fatal error on Gallery install Link to this post

    Hi guys,
    I'm just getting started with SS and today tried to install the Gallery module.

    Got so far as to try and create a new Gallery page and then I got this error message:

    Fatal error: Class 'ManyManyComplexTableField' not found in \mysite\gallery\code\GalleryPage.php on line 125

    Now I can't get even get into the administrator.

    This is only on a local dev server.
    Having read through the forums, and just to be on the safe side, I've already chmodded the Gallery folder and run db/build?flush=1? with no change.

    Any further suggestions?

    cheers,
    n

  • Andy
    Avatar
    230 Posts

    Re: Fatal error on Gallery install Link to this post

    The new version of the gallery module won't work with SilverStripe 2.0.2, you need 2.1.0-rc3 to use it.

  • nascent
    Avatar
    6 Posts

    Re: Fatal error on Gallery install Link to this post

    Thanks for the quick reply Andy. My eyesight must be failing to miss that.

    1631 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.