Jump to:

1851 Posts in 1606 Topics by 561 members

Blog Module

SilverStripe Forums » Blog Module » Blog 2.4

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2318 Views
  • baba-papa
    Avatar
    Community Member
    279 Posts

    Blog 2.4 Link to this post

    Does the Blog module work with SS 2.4 beta?

  • Willr
    Avatar
    Forum Moderator
    5508 Posts

    Re: Blog 2.4 Link to this post

    Probably faster to try it out for yourself! You'll probably want to use the latest daily build / trunk for 2.4 compatibility

  • baba-papa
    Avatar
    Community Member
    279 Posts

    Re: Blog 2.4 Link to this post

    It works!

  • Mo
    Avatar
    Community Member
    508 Posts

    Re: Blog 2.4 Link to this post

    Blog hasn't worked for me for a little while now in 2.4. Keep getting:

    PHP Fatal error: Class 'DatetimeField' not found in /Users/morvenlewis-everley/Documents/NetbeansProjects/Silverstripe/cello_main/blog/code/BlogEntry.php on line 80, referer: http://localhost:8081/cello_main/admin/cms/

    I am using the trunk version of blog. I know DatetimeField has been depreciated in 2.4, but I wasn't aware it had been in the Beta 1 release?

    I am checking Silverstripe out of /tags/beta/2.4.0-beta1/, is this the best place to check 2.4 out of?

    Cheers,

    Mo

  • dotperinch
    Avatar
    Community Member
    1 Post

    Re: Blog 2.4 Link to this post

    Hello!

    baba-papa posted this after I tried the frontend part of the blog module where I was able to create a fresh blog post without any problems or obstacles. In the backend I still get the same fatal php error as you do.

    Bye
    - Markus

  • Willr
    Avatar
    Forum Moderator
    5508 Posts

    Re: Blog 2.4 Link to this post

    Mo - upgrade to the latest 2.4 build. The date time functionality has been refactored in 2.4 but if you are using the beta it won't be included. Blog trunk has been updated to fit that new post 2.4 beta API - http://open.silverstripe.org/changeset/99407/modules/blog/trunk

  • edk
    Avatar
    Community Member
    39 Posts

    Re: Blog 2.4 Link to this post

    I have my svn client (running Cornerstone on MacOs) pointing to the following two repositories and have not had an issue with the Blog in a while.

    For SS 2.4: http://svn.silverstripe.com/open/phpinstaller/branches/2.4
    For Blog: http://svn.silverstripe.com/open/modules/blog/trunk

    Works a charm...I just now have to figure out how BlogTrees work in relation to Holders and Entries....

  • Mo
    Avatar
    Community Member
    508 Posts

    Re: Blog 2.4 Link to this post

    I switched back to branches/2.4 and now everything seems to be working,

    Cheers,

    Mo

    2318 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.