Jump to:

1856 Posts in 1610 Topics by 562 members

Blog Module

SilverStripe Forums » Blog Module » Blog Module Front-End WYSIWYG Image?

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1614 Views
  • Media Contour
    Avatar
    Community Member
    33 Posts

    Blog Module Front-End WYSIWYG Image? Link to this post

    I don't see a button to add an image in the WYSIWYG editor that appears on the form after clicking on the Blog Management widget.

    Is it even possible to add it?

  • boosis
    Avatar
    Community Member
    8 Posts

    Re: Blog Module Front-End WYSIWYG Image? Link to this post

    Did you find a solution for this?

  • danzzz
    Avatar
    Community Member
    175 Posts

    Re: Blog Module Front-End WYSIWYG Image? Link to this post

    Also interessted in a solution.

  • allenmccabe
    Avatar
    Community Member
    5 Posts

    Re: Blog Module Front-End WYSIWYG Image? Link to this post

    The following JavaScript is necessary to get the WISYWIG working on the front-end anyway; notice "image" at the end of the "theme_advanced_buttons1" value:

    if (typeof tinyMCE != 'undefined' && typeof tinyMCE.init == 'function') {
       tinyMCE.init({
          document_base_url: "/",
          theme : "advanced",
          mode: "textareas",
          theme_advanced_toolbar_location : "top",
          theme_advanced_buttons1 : "formatselect,|,bold,italic,underline,separator,justifyleft,justifycenter,justifyright,justifyfull,separator,outdent,indent,separator,undo,redo|image",
          theme_advanced_buttons2 : "",
          theme_advanced_buttons3 : "",
          plugins : "inlinepopups",
          height:"600px",
          width:"610px"
       });
    }

    1614 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.