Jump to:

1835 Posts in 1139 Topics by 554 members

Blog Module

SilverStripe Forums » Blog Module » Blog archive widget by year is broken

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 900 Views
  • MarijnKampf
    Avatar
    Community Member
    161 Posts

    Blog archive widget by year is broken Link to this post

    I'm using a fresh install of SilverStripe 2.4.5 en Blog 0.4.1. When setting the Blog Archive Widget to year, all blog results are shown rather than only the entries from that specific year. Is this a know bug, or should I open a bug ticket?

  • Willr
    Avatar
    Forum Moderator
    5462 Posts

    Re: Blog archive widget by year is broken Link to this post

    Not the same issue as http://open.silverstripe.org/ticket/6306 is it?

  • Bruce B
    Avatar
    Community Member
    145 Posts

    Re: Blog archive widget by year is broken Link to this post

    Have a look at this ticket:
    http://open.silverstripe.org/ticket/5667

    This still applies to blog 4.1. I haven't tried downloading the latest trunk but it should have the fixes incorporated. Unfortunately the SS web site doesn't want to play nice and allow access to trunk downloads at the moment so I can't confirm this..

  • MarijnKampf
    Avatar
    Community Member
    161 Posts

    Re: Blog archive widget by year is broken Link to this post

    Yes, those are the same issues. I'll wait until the trunk build is available.

  • Willr
    Avatar
    Forum Moderator
    5462 Posts

    Re: Blog archive widget by year is broken Link to this post

    Unfortunately the SS web site doesn't want to play nice and allow access to trunk downloads at the moment so I can't confirm this..

    If you run into any issues with the website use the Feedback link at the bottom of the page so someone can take a look at it.

  • Pipifix
    Avatar
    Community Member
    54 Posts

    Re: Blog archive widget by year is broken Link to this post

    The trunk (Build Date: 2011-03-09) is now accessable and the archive links plays nice now.

    FYI: in BlogSummary.ss
    The line: <p>$ParagraphSummary.LimitWordCountPlainText(60)</p> is changed to <p>$Content.FirstParagraph(html)</p>

    If its neccessary you have to change your template.

    Thomas

    900 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.