Jump to:

1842 Posts in 1600 Topics by 558 members

Blog Module

SilverStripe Forums » Blog Module » Pictures in Blog entries?

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 3744 Views
  • SWRL149
    Avatar
    Community Member
    7 Posts

    Pictures in Blog entries? Link to this post

    Just wondering if anything ever cam of any of the strings involving trouble placing pictures in a blog entry? i've seen one post but it doesn't seem to have gone anywhere. I'm no developer, just a graphic designer that would really like a picture to accompany a posting.

    Was there a work around that actually solved the problem fully? bebabeba posted what seemed to be a fix but only working on the unpublished page.

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Pictures in Blog entries? Link to this post

    What isn't working for you ?

  • HanSolo
    Avatar
    Community Member
    83 Posts

    Re: Pictures in Blog entries? Link to this post

    I agree with you blog 0.1 did work much better, everytime I place I new blogentry I always have to do some changes to the code.
    One thing I noticed is when I insert an image that is let say 600px in width. If I want to scale it down to 400px, the div that contain the the images is 600pc width: all of this can make the design look like...shit.
    I dont know if this is a bug or not. But as I said the blog 0.1 was much more stable.

  • SWRL149
    Avatar
    Community Member
    7 Posts

    Re: Pictures in Blog entries? Link to this post

    At least you can get pics into your entry. It will let me pick a picture, but when i hit enter, it just sits there. no broken link pic, no place holder, not even a cup of coffee while i wait. It totally ignores me. And that's what hurts the most.

    I'm gonna git my server to upgrade a couple of things and see if that helps. I'm crossing my wires in hopes that it does.

  • SWRL149
    Avatar
    Community Member
    7 Posts

    Re: Pictures in Blog entries? Link to this post

    So we upgraded to the most recent 2.3.2 and updated the blog module. Why in the name of all that is sacred to bloggers is there no way to add an image or a hyperlink?? Has anyone out there written some nice adjunct that i can poach and add somewhere that would give me the ability to use the wysiwig tools that are displayed in the control panel? I just wanna be able to insert a small image related to my blog entry and if needed, highlight a word or 2 and use the link button to add a URL. I mean, i've come so far in silverstripe and it seems to be a respected platform. Please don't tell me I need to scrap what i've built and convert to wordpress. ugh.

  • dab
    Avatar
    Community Member
    50 Posts

    Re: Pictures in Blog entries? Link to this post

    I think you should add one line to your mysite/_config.php:

    BlogEntry::allow_wysiwyg_editing();

  • Benoit
    Avatar
    Community Member
    2 Posts

    Re: Pictures in Blog entries? Link to this post

    That BlogEntry::allow_wysiwyg_editing(); works fine, except...

    in the admin panel now I have the editor tools, and in the Blog itself (the actual site) I have them in Internet Explorer, but in Firefox nothing happens, allthough in Firefox the script activates when on the admin site...

    Is there a fix for that ?

  • Philwm
    Avatar
    Community Member
    22 Posts

    Re: Pictures in Blog entries? Link to this post

    Hope someone here can shed some light on this; I loaded the blog v0.2.1 and made some layout changes to put the widgets at the top of the blog page and bring the content across further to the left.

    Before and after these changes - so I don't think it has anything to do with them, they were to Page.ss and Sidebar etc - I have quite a bit of trouble getting much control over pictures, especially text wrapping and alignment.

    I had changed the code to allow the WYSIWYG editor already.

    I have seen this problem in the earlier SS editor that needed to be corrected in the html, and I could do it here but my client needs to be able to add pictures to the blog without resorting to any coding!

    I'd also like to change the point at which the module cuts short the blog entry - there's a problem putting an image in that shows on the blog mainpage otherwise, anything over about 200px gets bumped to the read full entry?

    3744 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.