Jump to:

1851 Posts in 1606 Topics by 561 members

Blog Module

SilverStripe Forums » Blog Module » Embed YouTube videos

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 4752 Views
  • animasola
    Avatar
    Community Member
    121 Posts

    Embed YouTube videos Link to this post

    How do you embed youtube videos in blog posts?

  • animasola
    Avatar
    Community Member
    121 Posts

    Re: Embed YouTube videos Link to this post

    Up

    Anyone?

  • cliersch
    Avatar
    Community Member
    75 Posts

    Re: Embed YouTube videos Link to this post

    You could change Content field typ to "HTMLTextField" and post it from the CMS (use the HTML Editor)!

  • jovoo
    Avatar
    Community Member
    12 Posts

    Re: Embed YouTube videos Link to this post

    Hello everyone,

    is it possible to use the HTMLTextField in a DataObject, somehow? I would like to use DataObjects instead of Pages in every subcategory. But I haven't found a way to embed youtube videos there, yet.

    Any ideas for a solution?

    Cheers
    jovoo

  • mrwindupbird
    Avatar
    Community Member
    26 Posts

    Re: Embed YouTube videos Link to this post

    I would love some help with this as well. I tried changing the Content class to HTMLEditorField which seemed to work fine in CMS however when displayed on the website all the HTML was displayed as text. i.e. - <p>'s and youtube embedding code was displayed as normal text... Learning a lot as I work through this, any help is greatly appreciated!

    Thanks!

  • SightUnseen
    Avatar
    Community Member
    28 Posts

    Re: Embed YouTube videos Link to this post

    I have the following in the /mysite/_config.php file which disables bbcode and utilises TinyMCE instead:

    BlogEntry::allow_wysiwyg_editing();

    which allows Youtube entries, as seen here: http://crew.org.nz

  • mrwindupbird
    Avatar
    Community Member
    26 Posts

    Re: Embed YouTube videos Link to this post

    BlogEntry::allow_wysiwyg_editing();

    ...I'm afraid I don't know what this does.. I included it in _config.php and nothing appears to have changed...

  • mrwindupbird
    Avatar
    Community Member
    26 Posts

    Re: Embed YouTube videos Link to this post

    Wondering if anyone else has some idea as to what might be the problem?

    4752 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.