Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Issues in Modules since Upgrade


Reply


6 Posts   992 Views

Avatar
owaiskl

Community Member, 16 Posts

5 December 2009 at 4:54pm

Hello everyone,

So I recently started work on a friends silverstripe website, and I didn't know much about it and have been teaching myself how to work and edit the sit over the course of a month. Recently I updated the software to the latest 2.3.4 version hoping it would fix some bugs that had existed in the older one. Instead, it won't allow me to use the gallery and newsletter modules anymore, giving me the attached errors for each. With the gallery module I already spent a few hours trying everything that I could find in the documentation and the forums, and I even reset the db and started with a fresh install of the module, and now everytime I try to select the extension to show images, it will crash, and if I deselect all the extensions, I get a blank template page, but nothing else. yes, I checked the permissions. The newsletter used to work fine, but now I click on it in the admin page and I get the attached error screen.

Any guidance would be appreciated

Thanks

Attached Files
Avatar
davidm2010

Community Member, 107 Posts

6 December 2009 at 5:46am

I would remove all of the modules, rebuld the site, then install the modules fresh. Move all of you module folders off line, any custom PHP, do a build for the site, then begin to add the modules back. It seems to me you are having conflict issues inside the database. By doing a build with no modules, it should clean up the database and allow the modules to work properly.

David

Avatar
ajshort

Community Member, 244 Posts

6 December 2009 at 7:44am

Actually, you don't need to do any of that. All you need to do is upgrade the newsletter module to the latest 2.3 compatible version from SVN (which is probably trunk). The gallery module however has not been maintained for ages and ages and is probably not compatible with 2.3.4. The Image Gallery module is probably the best alternative to use.

Avatar
owaiskl

Community Member, 16 Posts

6 December 2009 at 2:36pm

Thanks for that, I got rid of the old Gallery module, and now have a functioning Image Gallery. I am still having trouble with the Newsletter Module as it won't allow me to add members to the Mailiing List, either through the CMS or the subscription page I generated with the newsletter module OR the userform module I installed later. My understanding by now is that the issue is somewhere in the code of the Newsletter module which is making it problematic with adding users in version 2.3.4.

I am running the latest trunk of the newsletter, though I had the same issue with the stable build.

Any ideas?

Avatar
joninjas

Community Member, 32 Posts

6 December 2009 at 2:51pm

Just something you might be interested in (but I'm still using Silverstripe 2.3.3):

For a working Newsletter subscription validation change the lines 140+141 in SubscriptionPage.php (version: newsletter-trunk-r94397) to:

Requirements::javascript("http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js");
Requirements::javascript("http://ajax.microsoft.com/ajax/jquery.validate/1.5.5/jquery.validate.min.js");

For adding users to a list always first define a newsletter type under the tab 'newsletter' and choose a group you defined before under security. Then choose in the page subscription form the right newsletter for 'Select the newsletters that you want the user subscript to'. But I'm still using 2.3.3.
Probably something important changed? http://open.silverstripe.org/wiki/ChangeLog/2.3.4

cheers
Jonas

Avatar
owaiskl

Community Member, 16 Posts

6 December 2009 at 3:38pm

Finally. Thank God for you sir, it works now! And i'm on 2.3.4, still.

Great, now I can get some sleep :D