Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

2 modules I made


Go to End
Reply


23 Posts   6593 Views

Avatar
lanks

Community Member, 61 Posts

11 September 2010 at 8:04pm

Hi roterl

I really like the widgets manager. I am having some trouble using it however. Where I create a new 'Managed Widgets Area Holder', add my widgets and then save it the widgets are re-ordered in some random order. If I then go back, reorder them and save again it just saves them back to the original order.
If you can give me any ideas as to why this is happening or a fix that would be great.

Thanks
Liam

Avatar
Bauer-CTU

Community Member, 10 Posts

28 September 2010 at 6:05am

Edited: 28/09/2010 6:10am

Hi,
Upon saving the WidgetsManager is re-ordering my widgets as well, just like the previous poster is experiencing.
For me it seems to work fine with 4 widgets but when I add a 5th widget it re-orders them.

Does anyone know how to solve this?

Many thanks in advance. :-)

Avatar
Aljoscha

Community Member, 2 Posts

21 November 2010 at 10:27pm

Hi there!

I need help with the WidgetManager:

I'm new to SilverStripe. I installed the calendar module and the calendar widget, created a new calendar and some events.
Now I want to show the calendar widget at the frontpage - I use BrightSide1 as template.
So I installed - seems to be the easiest way - the WidgetManager and created a WidgetHolder, have named it and chosen the calendar widget and the calendar.
In the page.ss of BrightSide1 I added $SidebarWidgets after the SideNav-tag.
I flushed the site but nothing appears.

Where is my mistake?

Thanks a lot for your help.
Aljoscha

Avatar
GrizzlyGroundswell

Community Member, 10 Posts

14 December 2010 at 2:27pm

Edited: 15/12/2010 3:02am

Thank you for this widgetmanager! It makes it so much easier for this newbie! However, can you let me know where exactly I place the $widgetmanager ? I know it is a newbie question, but I am still learning SilverStripe! My theme is "fancypants" and my site is www.theodoremedia.com Thank you in advance!

Update: It took me a while, but after putting $SidebarWidgets in mytheme/template/layout/page.ss and _page.ss It worked like a bloody Rippa! Thanks so much for all your hard work! Still learning here!

Avatar
GrizzlyGroundswell

Community Member, 10 Posts

4 January 2011 at 9:41pm

so far so good in 2.4.4!

Avatar
Anirath

Community Member, 7 Posts

23 February 2011 at 1:18pm

I seem to be having an issue with the latest Widget Manager. I used the "Widgets Manager" tab and created a new Widget Area and added the LoginWidget I wanted to use. Then I went to the page and used the "content/managed widgets" and selected Managed then selected my widget area and saved. However, it doesn't show on the page when I flush the cache. Any help?

Avatar
Anonymous user

Community Member, 8 Posts

9 April 2011 at 1:44pm

Hi Roterl

I'm having trouble getting the Widget Manager to work properly in SS 2.4.4.

I have it installed and the $SidebarWigets in the navigation.ss page

The Managed widgets tab shows up in the CMS OK but the only way I can get any widgets to display is to make select "Self" managed. IF I select any other option they don't show up at all. I also wanted to have a widget on every page - say quicklinks but I can't make that work either. Any ideas?

Cheers
Pete

Go to Top