Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

ImageGallery thumbnail's don't load in IE 6-8


Reply


5 Posts   1752 Views

Avatar
okotoker

Community Member, 41 Posts

24 December 2009 at 7:25am

The gallery works and function in all other browsers. I get a error in ie that says:

Line: 3
Char: 2
Error: Object doesn't support this property or method
Code: 0
URL: http://65.60.53.10/~artfulli/image_gallery/javascript/imagegallery_init?m=1251487030

You can see the page here: http://65.60.53.10/~artfulli/furniture/album/living-room-2

Avatar
okotoker

Community Member, 41 Posts

24 December 2009 at 10:16am

Solved it:

There must be a conflict somewhere with the variable name used in the "imagegallery_init.js" with something else being used elsewhere. I just changed gallery to mygallery and everything snapped into place.

Oddly, it was just IE throwing the error here as firebug showed no problems.

Avatar
UncleCheese

Forum Moderator, 4096 Posts

24 December 2009 at 11:03am

Yeah, I was just looking at that. It's kind of weird that function doesn't use jQuery. I can see what I was thinking, making it framework-independent, but since so many of the plugins are jQuery based anyway, maybe I should just require it. That way, naming collisions like that won't happen.

Avatar
pinkp

Community Member, 168 Posts

11 August 2010 at 2:20am

Edited: 11/08/2010 2:28am

"I just changed gallery to mygallery "

I also have this issue when you say you changed it, what did you change? the module folder name or something else?

thanks!

EDIT SOLVED

Changed it in: imagegallery_init.js

Avatar
trumps

Community Member, 1 Post

10 July 2011 at 11:15pm

I have similar problem with Mozila, where the thumbnails show and blank placeholder (even if the image chosen has a thumbnail in the add image page)

I have read in other forums that this could be a privilege problem. Tried changing privileges with no improvement
This thread suggests changing "gallery" to Mygallery"

Please advise which part of the below text requires changing.

// We'll avoid relying on any specific JS framework to keep this open.
window.onload = function() {
   if(gallery = document.getElementById('gallery-list'))
      gallery.className = "gallery-layout loaded";
}