Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Workflow module problems installing


Reply

4 Posts   1639 Views

Avatar
Harley

24 January 2010 at 2:35am Community Member, 153 Posts

Hello,

I've tried installing the workflow module and the latest trunk, both of which give me the error posted at the bottom. It says it is compatible with SS version 2.4 but is it backwards compatible too? I'm currently running version 2.3.4.

Thanks

------------------------------------------------------------------------------------------------------------------------

Warning: fopen(C:\Users\Bob\AppData\Local\Temp\/silverstripe-cacheG--Program-files-xampp-htdocs-wwwroot-devicestudio/manifestClassParse-G__Program files_xampp_htdocs_wwwroot_devicestudio_cmsworkflow_code_ThreeStep_sidereports_ThreeStepWorkflowPublicationRequestsNeedingApprovalSideReport.php) [function.fopen]: failed to open stream: No error in G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\ManifestBuilder.php on line 398

Warning: fopen(C:\Users\Bob\AppData\Local\Temp\/silverstripe-cacheG--Program-files-xampp-htdocs-wwwroot-devicestudio/manifestClassParse-G__Program files_xampp_htdocs_wwwroot_devicestudio_cmsworkflow_code_ThreeStep_sidereports_ThreeStepWorkflowPublicationRequestsNeedingPublishingSideReport.php) [function.fopen]: failed to open stream: No error in G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\ManifestBuilder.php on line 398

Warning: fopen(C:\Users\Bob\AppData\Local\Temp\/silverstripe-cacheG--Program-files-xampp-htdocs-wwwroot-devicestudio/manifestClassParse-G__Program files_xampp_htdocs_wwwroot_devicestudio_cmsworkflow_code_ThreeStep_sidereports_ThreeStepWorkflowRemovalRequestsNeedingApprovalSideReport.php) [function.fopen]: failed to open stream: No error in G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\ManifestBuilder.php on line 398

Warning: fopen(C:\Users\Bob\AppData\Local\Temp\/silverstripe-cacheG--Program-files-xampp-htdocs-wwwroot-devicestudio/manifestClassParse-G__Program files_xampp_htdocs_wwwroot_devicestudio_cmsworkflow_code_ThreeStep_sidereports_ThreeStepWorkflowRemovalRequestsNeedingPublishingSideReport.php) [function.fopen]: failed to open stream: No error in G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\ManifestBuilder.php on line 398

Warning: fopen(C:\Users\Bob\AppData\Local\Temp\/silverstripe-cacheG--Program-files-xampp-htdocs-wwwroot-devicestudio/manifestClassParse-G__Program files_xampp_htdocs_wwwroot_devicestudio_cmsworkflow_code_TwoStep_sidereports_TwoStepWorkflowPublicationRequestsNeedingPublishingSideReport.php) [function.fopen]: failed to open stream: No error in G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\ManifestBuilder.php on line 398

Warning: fopen(C:\Users\Bob\AppData\Local\Temp\/silverstripe-cacheG--Program-files-xampp-htdocs-wwwroot-devicestudio/manifestClassParse-G__Program files_xampp_htdocs_wwwroot_devicestudio_cmsworkflow_code_TwoStep_sidereports_TwoStepWorkflowRemovalRequestsNeedingPublishingSideReport.php) [function.fopen]: failed to open stream: No error in G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\ManifestBuilder.php on line 398

Warning: Unknown class passed as parameter in G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\Object.php on line 445

Fatal error: Uncaught exception 'ReflectionException' with message 'Class SiteConfig does not exist' in G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\Object.php:273 Stack trace: #0 G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\Object.php(273): ReflectionClass->__construct('SiteConfig') #1 G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\Object.php(420): Object::uninherited_static('SiteConfig', 'extensions') #2 G:\Program files\xampp\htdocs\wwwroot\devicestudio\cmsworkflow\_config.php(13): Object::add_extension('SiteConfig', 'SiteConfigTwoSt...') #3 C:\Users\Bob\AppData\Local\Temp\silverstripe-cacheG--Program-files-xampp-htdocs-wwwroot-devicestudio\manifest-main(6427): require_once('G:\Program file...') #4 G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\ManifestBuilder.php(70): require_once('C:\Users\Bob\Ap...') #5 G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\Core.php(150): ManifestBuilder::include_manifest() #6 G:\Program files\xamp in G:\Program files\xampp\htdocs\wwwroot\devicestudio\sapphire\core\Object.php on line 273

Avatar
Willr

26 January 2010 at 8:44pm Forum Moderator, 5511 Posts

No. Workflow is not backwards compatible. You must be running SilverStripe 2.4 to use workflow.

Avatar
Harley

26 January 2010 at 11:28pm Community Member, 153 Posts

Ah ok, any ideas of when a beta version will be available for 2.4?

Thanks

Avatar
Willr

27 January 2010 at 11:59am Forum Moderator, 5511 Posts

No fixed date for 2.4 but there is about 20 tickets remaining that have been assigned to the milestone. http://open.silverstripe.org/milestone/2.4.0%20beta so its not far away.