Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Problem with Gallery Module and question header backround‏


Reply


2 Posts   758 Views

Avatar
vinz

Community Member, 13 Posts

8 February 2010 at 10:27am

Hi there,
my name is Vinz and I'm a new member of silverstripe CMS, i really like this product but I still have to understand a litle bit how it works. By the way sorry if my english is not that good.

My first query is how do I install the gallery module.
I did the following:
- download the module;
- but it on root;
- then I did mysite/db/build but then i get the message of error the page can not be displayed.
I downloaded the last silverstripe CMS SilverStripe-v2.3.5 and the last gallery module gallery-v0.2.3.

What do I do wrong?

The second question is how can I do thet the header backround image of the header changes automatically from different images or is it possible to have a different header image for each tab, what I don't thing it's possible because the header is for the entire page....hope you understand what I mean. In oder words I would like to have 4-5 pictures that changes after 3-4 seconds so thet i can put some "fresh style" in the page.

I really hope you can give me a hint.

Thank you very much.

Avatar
Double-A-Ron

Community Member, 604 Posts

8 February 2010 at 11:07am

Edited: 08/02/2010 11:10am

Hi Vinz, welcome to the world of SS,

For your first problem, the proper URL is /dev/build. /db/build is the old URL, but it should still work. I haven't tried 2.3.5 yet so not sure if that old URL is completely depreciated or not. I'm sure someone here will confirm.

If the error you are seeing is not a 404 error, you will need to be more specific about the error. Putting your site into dev mode provides you with more detailed error messages. http://doc.silverstripe.org/doku.php?id=debugging&s=devmode

The second question is really design related. All you need to do for this is build the HTML that does this swapout with javascript, and then embed that in your /themes/mythem/templates/Page.ss.

I have done one Silverstripe site that does what I think you are asking: http://www.vivaexpeditions.com/. The slideshow at the top has nothing to do with Silverstripe. It is only embedded in the Page.ss file as you would any old webpage.

If this is still not clear, I suggest you go through the Silverstripe tutorials here: http://doc.silverstripe.org/doku.php?id=tutorials. They are a very good starting point for the way the systems work, and the very first one guides you through how the templates work.

Ta
Aaron