Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Mollom (Audio Feature) problems


Reply


4 Posts   1453 Views

Avatar
Hello_electro

Community Member, 80 Posts

24 February 2010 at 2:17pm

I have noticed that on Molloms website their audio assist feature is very different from how the one downloaded from SS works. It seems theirs is cross browser functional.

The current SS module sees to have issues with working effectively on all browsers. I also had a client tell me his is autoplying. I think this is an issue with either him having an old version of a browser or some weird setting. Not sure though.

Has anyone else experienced these types of issues? Any solutions?

Avatar
martimiz

Forum Moderator, 1132 Posts

3 March 2010 at 1:35am

Hi Hello-electro

The mollom site uses Drupal for it's CMS. I don't 'know' Drupal, but I did download the module to have a look. The Drupal Mollom implementation looks to be totally different from SilverStripe's, in that it doen't even seem to use the official mollom.php library, as SilverStripe does. The library uses a simple <object type="audio/mpeg" ... > tag, where Drupal uses a flash player, jQuery and Ajax.

For me, I usually disable the audio captcha, just for the time being...

Avatar
Hello_electro

Community Member, 80 Posts

3 March 2010 at 2:49am

Yeah, that is exactly what I did! It's a bummer that Mollom isn't cross browser compatible via SS. I found an interesting article about Re-Captcha customization that I will post in a bit. I have stayed away from that system because i wasnt sure how to change the styling of the module outside of color scheme. The article is pretty good at showing you how to do basically anything you want with the module including width which was the biggest issue.

Thank, Martimiz.

Avatar
Thomashv

Community Member, 33 Posts

28 August 2014 at 2:04am

Edited: 28/08/2014 2:22am

Hi guys!

I see that these posts are quite old, but I try my luck and throw in a question in this thread. I have set up the SpamProtector 0.4 and Mollom 0.3 on a customers site. I recommended them to upgrade to SS 3.1.6, but they are not ready for that until after new year. So to get rid of the spam they get in their mailbox I am doomed to set this up with old versions of everything.

I've got it working, but the voice when loading their contact page is quite annoying. There are not any buttons for hearing the sound one more time either. (Not any button for switching the re-captcha in firefox, safari, and chrome on OS X either, but I believe we'll have to live with that). So when it comes to all I see no meaning about bother the users with the voice.

So my question is. How did you turn it of?

---------------

Edit:
Found out that I just could comment out a couple of lines in the mollom/code/MollomField.php

if($this->showCaptcha() ) {
      
         $mollom_session_id = Session::get("mollom_session_id");
         $imageCaptcha = MollomServer::getImageCaptcha($mollom_session_id);
         // $audioCaptcha = MollomServer::getAudioCaptcha($mollom_session_id);
         
         Session::set("mollom_session_id", $imageCaptcha['session_id']);
            
         $captchaHtml = '<div class="mollom-captcha">';
         $captchaHtml .= '<span class="mollom-image-captcha">' . $imageCaptcha['html'] . '</span>';
         // $captchaHtml .= '<span class="mollom-audio-captcha">' . $audioCaptcha['html'] . '</span>';
         $captchaHtml .= '</div>';
         
         return $html . $captchaHtml;
      }