Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

CMSWorkflow Module wont install


Go to End
Reply


13 Posts   2729 Views

Avatar
patjnr

Community Member, 101 Posts

10 April 2010 at 7:04pm

Thanks WIll

it worked.

ta

PAt

Avatar
Tama

Community Member, 132 Posts

24 May 2010 at 10:11am

I'm getting the following error on installing Workflow:

Fatal error: Class 'PopupDateTimeField' not found in /var/www/dev01/workflow/code/batchactions/BatchSetEmbargo.php on line 19

This is directly installed from the following SVN: http://svn.silverstripe.com/open/modules/cmsworkflow/tags/rc/1.0-rc3/

We're running 2.4, do we need to install legacydatefields as suggested by Willr for this to work?

Avatar
Tama

Community Member, 132 Posts

24 May 2010 at 1:44pm

I installed legacydatefields from: http://svn.silverstripe.com/open/modules/legacydatetimefields/trunk/ - and everything is now working fine.

Avatar
mark_s

Community Member, 78 Posts

24 May 2010 at 8:22pm

Hi.

FYI, legacydatatimefields was introduced for modules that have not been migrated to the new date field classes introduced with 2.4. The short-medium term plan with cmsworkflow is to wean it off legacydatetimefields.

Mark

Avatar
SilverDan

Community Member, 5 Posts

10 December 2010 at 1:43pm

Edited: 16/12/2010 1:56pm

Just thought I'd post in this thread, as I had a couple of minor issues with CMSWorkflow:

I have a clean install of SS 2.4.2 and installed CMSWorkflow Module rc4. The Embargo and Expiry date and time functions (and popup datepicker timepicker) weren't working at all. I then installed the legacydatetimefields module which had no effect on the Embargo and Expiry functionality or date/time pickers either.

I just downloaded and installed the older rc3 version of CMSWorkflow and this is now working as expected with all functionality including the old date/time pickers.

So there could be some issue with the CMSWorkflow rc4 version with SS 2.4.2 and the following modules: dataobject_manager, image_gallery, uploadify - thought it might be worth a mention for anyone else struggling to get it working.

UPDATE: 16/12/2010

I just realised that some of the functionality with CMSWorkflow had dropped off when I reverted to rc3! Although the Date and Time fields/functionality began working correctly with rc3, the ability for publishers to actually publish or unpublish pages was lost! Obviously, this won't do, so I'm going back to rc4 and will have to do without functioning embargo/expiry! Anyone else having the same issue?

Go to Top