Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Subsites, root folder for file chooser?


Reply


3 Posts   1274 Views

Avatar
Wilson

Community Member, 63 Posts

31 March 2010 at 7:56am

Hi everyone,

In the CMS, has anyone been able to hide asset folders not owned by the selected Subsite for the user when using File Chooser, for example in the link tool? I thought it was working like this at one point, but now I see all of the directories for every subsite.

I'm on 2.4 beta1.

Thanks for any advice! And also, please let me know if it is actually supposed to be working like this and I've either messed it up or have incompatible version of subsites module.

Thanks!
Wilson

Avatar
kindlemanwill

Community Member, 69 Posts

4 November 2011 at 12:42pm

Bump.

This seems to be broken. I'm getting the same results as Wilson - all the files and folders are shown when attaching an image but if you select one that is owned by a different subsite, it doesn't attach. No error message.

Will

Avatar
kindlemanwill

Community Member, 69 Posts

7 November 2011 at 2:15pm

As far as i can see, this just hasn't been implemented. There isn't anything thats trying to make the fields work with subsites.

I've tried to have a look at how to extend ImageField or probably FileIFrameField but not got very far. any pointers on how to proceed would be awesome.

W