Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Preview: Postale Module


Reply

32 Posts   3124 Views

Avatar
UncleCheese

31 August 2010 at 2:10am 4085 Posts

Weird. Can you post a screenshot of your messages page?

Avatar
davidm2010

31 August 2010 at 2:17am Community Member, 107 Posts

Here you go.

Attached Files
Avatar
UncleCheese

31 August 2010 at 2:42am 4085 Posts

That looks like a forum page. Do you have a screenshot of the messages page?

Avatar
davidm2010

31 August 2010 at 2:43am Community Member, 107 Posts

I don't see a message page.

Avatar
UncleCheese

31 August 2010 at 2:51am 4085 Posts

You need to set the URL for your messages page. See http://doc.silverstripe.org/postale#usage

Avatar
davidm2010

31 August 2010 at 3:09am Community Member, 107 Posts

Thanks Cheese man, I got that part (I wasn't clear on your instructions for the URL I am use to seeing "http://mysite/messages" )

So, I have that working, but when I hit send, the message box does not disappear. This is in IE8 and FireFox 3.6. I expected the message box to close.

Avatar
UncleCheese

31 August 2010 at 3:17am 4085 Posts

That's the intended behaviour. I'll look into auto-closing, though. I'm also going to add a SiteTree decorator that will allow you to put $SendMessageButton on any template, so you don't have to be in the messages controller to send a message.

Glad it's working for you!

Avatar
davidm2010

31 August 2010 at 3:27am Community Member, 107 Posts

Mr Cheese Meister, One test case you might want to try.

Use 1 sends a message to user 2,
user 2 replies. Works.

User 1 replies back to User 2 on the same thread.

If User 2 then deletes the thread. User 1 can no longer send messages to user 2 or user 2 doesn't receive them any longer for that thread.

Thanks for the hard work.