Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

flickr module and site search incompatible


Reply

2 Posts   951 Views

Avatar
vr

13 May 2010 at 2:22am Community Member, 9 Posts

Hi,

when I turn on site search by putting FulltextSearchable::enable(); in _config.php, the flickr gallery lightwindow preview stops working. On click on a thumb, nothing happens, js error msg is lightwindow-navigation is null. There seem to be conflicting js-libs. Anyone knows which libs to block? Tried willr's hints from another post, but that was a workaround for the gallery module, didn't help in this case.

cheers, vr

Avatar
CloudInfinity

17 February 2011 at 2:15am Community Member, 6 Posts

You need to block the standard prototype.js, prototype_improvements.js and behaviour.js files in order to make both elements work together. Between the

Requirements::javascript( "flickrservice/js/prototype.js" );
Requirements::javascript( "flickrservice/js/scriptaculous.js" );
Requirements::javascript( "flickrservice/js/lightbox.js" );

and

Requirements::css("flickrservice/css/lightbox.css");

Copy and paste the below section to block the files. I have included comments to briefly explain what and why etc.
You might need to check the locations for your version of SilverStripe etc.

// Block the following conflicting JS files to enable Full Text Search AND Lightbox.
// These two files are responsible for stopping the Lightbox from working.
Requirements::block("sapphire/thirdparty/prototype/prototype.js");
Requirements::block("sapphire/javascript/prototype_improvements.js");
// This file MUST be blocked to ensure the Full Text Search continues to work.
Requirements::block("sapphire/thirdparty/behaviour/behaviour.js");

Hope this helps if you haven't fixed it before now! ;o)