Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Gallery and SilverStripe 2.4


Reply

23 Posts   6013 Views

Avatar
JoelMurdoch

2 June 2010 at 6:05pm Community Member, 16 Posts

Bones, can you tell me what permissions you changed on what folders and files? I have the same problem and cannot seem to figure out what is going on.

Avatar
bones

2 June 2010 at 9:04pm Community Member, 104 Posts

Hi Joel
As I had built and tested the website on my Mac with MAMP, I just uploaded the website in one go. This meant that the "assets" directory, and the directories within it needed to be changed to 755. After this, it all worked perfectly.

Any new directories added once live (via SS) had the permissions set correctly.

I hope this helps :)

Avatar
JoelMurdoch

3 June 2010 at 11:15am Community Member, 16 Posts

Bones,

Thanks but not really. That WAS how it was setup.

I have given up trying to deal with this, I cannot keep giving my customers "I don't know as an answer". Am going to develop my own solution.

Avatar
Briohny

30 November 2010 at 11:12am Community Member, 199 Posts

Hi Boony,

I'm trying to install the gallery module with version 2.4.2 but having a few problems. Can you tell me what versions of DOM, image-gallery module and SWFUPLOAD you used to get it working on the latest version of SS? Thanks so much.

Avatar
sven

6 December 2010 at 10:25pm Community Member, 2 Posts

Hi Briohny,

The current versions of DOM and SWFUpload are working perfect, but I get a strange behavior from the gallery module itself. I can create a gallery page, but if I click on the page in the backend, I just got an error message box without text. Delete the gallery page doesn't work also.

Avatar
Briohny

6 December 2010 at 11:38pm Community Member, 199 Posts

Hi Sven,

I ended up giving up on the Gallery module. I've used it many times with previous versions of SS but I couldn't figure out how to get it to work with 2.4.2 I tried loads of variations/versions of DOM and SWFUpload but couldn't get it to work. It's a bummer because it's a great module, but I didn't have time to wait around or try and fix. Hopefully it'll get sorted soon.

Avatar
UncleCheese

7 December 2010 at 3:28am 4085 Posts

The module definitely works in 2.4. You can always test it on my demo site http://dataobjectmanager.carlinowebdesign.com (admin|password).

Your error could be a number of things, but you need to turn on your error reporting to find out so you don't just get a blank popup.

Also, SWFUpload is deprecated in favor of Uploadify. http://www.leftandmain.com/silverstripe-modules/2010/08/26/uploadify/

--------------------
SilverStripe tips, tutorials, screencasts and more: http://www.leftandmain.com

Avatar
cumquat

8 December 2010 at 2:40am Community Member, 198 Posts

Hi Uncle Cheese,

I have a couple of 2.43 installs with DOM, image gallery and uploadify and i do get some errors when i'm trying to use images that are already uploaded, so if i choose to add a picture to an album and it's already in an asset folder so i choose existing i get an error, attached is the error from your demo site when i try the same thing.

Hope you can help.

Mick

Attached Files