Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Event Calendar & SilverStripe 2.4


Reply


7 Posts   1834 Views

Avatar
maryfran

Community Member, 12 Posts

19 May 2010 at 2:09pm

Edited: 19/05/2010 2:11pm

Hi!

After trying to use this combination on a site I was building for a client (I am a designer, not a programmer), I can get the events to save to the calendar in the back end, but the calendar shows no events. This is on a clean install, r108 of Event Calendar and r395 of DataObjectManager.

There are no other modules, and it is using the default theme (I was trying to see if it was my custom page types causing a conflict - it isn't them, because they aren't there).

There are no errors, nothing. Just no events in the upcoming events (or on the calendar).

Any ideas?

Avatar
UncleCheese

Forum Moderator, 4096 Posts

19 May 2010 at 2:40pm

Can you replicate this issue on the demo site? http://eventcalendar.bluehousegroup.com/

Avatar
maryfran

Community Member, 12 Posts

20 May 2010 at 12:11am

Edited: 20/05/2010 12:14am

I can't...perhaps I did something wrong with installing the calendar? Was there something I needed to do in addition to using the most recent version?

I bookmarked a thread with a bunch of patches for the module, but they all seemed to be a bit older.

The events are there, they just aren't showing in the upcoming events or on the calendar... I feel like this is user error and I should be able to figure it out...

Thanks in advance for your help!

You can see what is happening here:

The event page itself works correctly http://rcw.originalmoxie.net/tesr/event1/

But the calendar shows nothing: http://rcw.originalmoxie.net/tesr/

And, when you click a link on the calendar, you get a link like this: http://rcw.originalmoxie.nethttp//rcw.originalmoxie.net/tesr/view/201005

(And thanks for your help last week with the DataObjectManager and my portfolio)

Avatar
maryfran

Community Member, 12 Posts

20 May 2010 at 12:31am

Update - I got the calendar working (really not sure what I did...really, I just went to sleep last night and woke up this morning and now it works).

But the links on the calendar are still doing the wonky thing where they add a full URL to the front end of the link...

Avatar
copernican

Community Member, 189 Posts

20 May 2010 at 1:04am

I recently installed the event calendar r108 and dataobject manager r395 to a fresh install of SS2.4.

my events are listing so I am not sure why your events will not list maryfran, but I am also having the same problem with clicking on links in the calendar for example

http://localhost/EventCalendarTest/workshops/
clicking on a day with an event in the calendar results in
http://localhosthttp//localhost/EventCalendarTest/workshops/view/2010-05-22

If I figure something out I will post my results here.

Avatar
UncleCheese

Forum Moderator, 4096 Posts

20 May 2010 at 5:16am

That bug is fixed in the latest rev.

Avatar
Graphicator

Community Member, 62 Posts

12 July 2010 at 8:24pm

Hey maryfran, Your purpleurbia site got me motivated to work with Silverstripe. Now12 forum threads in the Silverstripe forums, I was able to launch about three web site projects. I got the events calendar working fine in one of them: calfitnesscenter.com.