Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

CMS Workflow installation problems


Go to End
Reply

42 Posts   3678 Views

Avatar
Junglefish

7 June 2010 at 9:50pm Community Member, 104 Posts

Hi

I just upgraded my SilverStripe CMS from 2.3.3 to 2.4.0, so that I could start using the CMS Workflow module. However, I can't get the module to install properly at all.

I copy in the \cmsworkflow\ directory, run dev/build successfully, then fire up the CMS. At that point, all I get is the CMS welcome screen, with the little "Loading..." text top left, and that's it. It goes no further.

Removing the folder and re-running dev/build gets me working again, so I'm assuming that cmsworkflow must be finding a conflict with something else.

Listed below are all the additional modules I am running:
* dataobject_manager-r395
* event_calendar-r110
* legacydatetimefields-trunk-r100315
* userforms-v0.3.0
* swfupload-r375

The version of cmsworkflow is:
* cmsworkflow-v1.0-rc4

Is anyone aware of any known conflicts with these modules?

Or perhaps I am jumping to conclusions? Is it something else entirely that is preventing the CMS from loading up?

jf/

Avatar
patjnr

8 June 2010 at 1:28am (Last edited: 8 June 2010 1:33am), Community Member, 101 Posts

Hi

try removing extensions form the module folder

thx

Pat

Avatar
Junglefish

8 June 2010 at 1:44am Community Member, 104 Posts

Hi Pat

Explain that again? Which module folder? Which extensions?

jf/

Avatar
patjnr

8 June 2010 at 1:49am Community Member, 101 Posts

eg rename dataobject_manager-r395 to dataobject_manager.

They should be any problem working with workflow module as long as you have 2.4

ta

PJ

Avatar
Junglefish

8 June 2010 at 1:51am Community Member, 104 Posts

Oh, I see. No, they *are* already all named correctly, "dataobject_manager", "legacydatetimefields", etc. I just wrote the original post like that so that you all could see which versions of the modules I was using.

jf/

Avatar
patjnr

8 June 2010 at 1:59am Community Member, 101 Posts

Are you getting any PHP errors?
At times the problem is with the upgrade.
Try deleting Saphire and CMS and re-upload them it might work!

ta

P

Avatar
Junglefish

8 June 2010 at 2:16am Community Member, 104 Posts

>>Try deleting Saphire and CMS and re-upload them it might work!

Have done that several times when upgrading from 2.3.3 to 2.4.0. I had a lot of problems with having to upgrade both event_calendar and userforms to their latest versions because the versions I originally had were only compatible with 2.3.3. Anyway, in the end, I now have a fully working version of 2.4.0 with all of the modules nice and compatible. It was only then that I decided to add in cmsworkflow.

>>Are you getting any PHP errors?

No, I get nothing at all. The CMS just refuses to load. For the record, the website itself is fine and all functionality is running perfectly okay.

jf/

Avatar
Junglefish

8 June 2010 at 3:04am Community Member, 104 Posts

PS. There's this in php_error.log from earlier this morning:

[07-Jun-2010 09:26:50] PHP Warning: Module 'zip' already loaded in Unknown on line 0

But I'm not entirely convinced it's related...

Go to Top