Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Solved! - Subsites Module - what does this error mean?


Reply


5 Posts   1370 Views

Avatar
honeybunny

Community Member, 79 Posts

18 September 2010 at 1:40am

Edited: 24/09/2010 1:56pm

It's been a few months, I've upgraded to 2.4.1 and I am still unable to load the subsites module. In the past I was able to get the tables to load but had a variety of other problems saving, viewing or losing files, this time I can't even get the tables loaded. I've tried the most recent release and pretty much every daily trunk of the module since SS2.4.1 was released and get the same exact error message..

Fatal error: DataObject::buildSQL: Can't find data classes (classes linked to tables) for SubsiteDomain. Please ensure you run dev/build after creating a new DataObject. in /home/...

Can someone tell me what that means and how to fix it?

I don't know what my issue is with this particular module, but I'm waving the white flag and conceding defeat.

Thanks,

HB (one really desperate bunny)

Avatar
Willr

Forum Moderator, 5513 Posts

18 September 2010 at 11:42am

Sounds like SS can't find the file which contains the 'SubsiteDomain' class. Check your subsites/code/ folder for that class an ensure that you have run a /dev/build?flush=1

Avatar
honeybunny

Community Member, 79 Posts

20 September 2010 at 2:38am

Edited: 22/09/2010 12:30am

Sorry, I should have said that this was the error message I got when trying to do dev/build after loading the module. Also, I checked the subsitedomain.php file in the subsite/code folder but couldn't find anything weird, or to be more correct, I compared it against another version and it was the same. When I looked at the error message I assumed that it meant the subsitedomain.php file, but it is extremely possible that I was looking in the wrong place, hence my question. I've tried loading earlier and later version of the module to no avail. I just get the same error message when I do dev/build. I guess I am just completely lost about where else I should be looking.

Sorry to be so vague and rambling. I've been struggling with this wretched module off and on for months and at this point I may be completely mad. I can see it now. I'm sorry your honor my client is claiming insanity due to subsites. A perfectly reasonable justification for the acts of mad men and bunnies.

HB

Avatar
honeybunny

Community Member, 79 Posts

22 September 2010 at 1:55am

Edited: 22/09/2010 1:56am

I am still unable to get this thing to load. I've tried using the latest release version from the subsites page (http://www.silverstripe.org/subsites-module/), the latest trunk version (subsites-trunk-r108517.tar.gz) from the same page, and probably ten or twelve other versions, which may or may not have had any changes, from http://dailybuilds.silverstripe.com/modules-tarballs/. Every upload results in the same error message. I've tried unpacking the files locally and uploading as well as unpacking directly on the server. I've even tried reloading Sapphire. It made no difference.

I am way beyond the point of being lost. I haven't made any changes to any of the files in the subsites module and it's highly unlikely that every download I've tried is missing the same file. Is there anything else I should be looking for? I am desperate enough to consider completely wiping everything and starting over, but I would prefer to have some hope that it would actually make a difference.

HB (feeling like one of those cartoons where the character's head spins around and around with their eyes popping out...)

Avatar
honeybunny

Community Member, 79 Posts

24 September 2010 at 9:59am

Edited: 24/09/2010 2:01pm

I finally fixed it! After my week long monologue of subsite woe, I did a fresh install of SS, dropped all the tables and that seems to have fixed the problem. Subsites loaded with no errors now I can go to bed with a smile.

HB