Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Is GoogleSiteMap enabled by default?


Reply


5 Posts   1030 Views

Avatar
sajok

Community Member, 82 Posts

26 August 2010 at 3:45am

Hello,

I have just finished a site with 2.4.1 ss, and I want it to show in google's search but for now it doesn't seem to be detected by the googlebot. Did I miss any option to enable GoogleSiteMap module?!

thanks

Avatar
Willr

Forum Moderator, 5513 Posts

26 August 2010 at 9:52pm

So if you go to http://yoursite.com/sitemap.xml do you get the generated sitemap?

Check you have the googlesitemaps folder in your SilverStripe root. I'm pretty sure thats all you need to do to enable it. You can enable automatic google pinging by adding this to your _config file

GoogleSiteMap::enable_google_notification();

Avatar
sajok

Community Member, 82 Posts

29 August 2010 at 2:05am

Hi Willr,

thanks for replying.. The url :http://www.mysite.com/sitemap.xml shows the xml file's latest update. The module folder is in the root with the name"googlesitemaps". I didn't change anything inside that folder. In the google's webmaster tools page, I verified the site url and uploaded the sitemap.xml, It appears uploaded correctly. I did this three days ago but still shows no data on their dashboard.
I have just checked again and the website is not indexed by google yet..!

?

Avatar
Willr

Forum Moderator, 5513 Posts

29 August 2010 at 2:16pm

Well if that xml is showing then thats everything that the module can do. Its all up to google now. Have you tried submitted your site to the search database - http://www.google.com/addurl/?continue=/addurl ?

Avatar
sajok

Community Member, 82 Posts

31 August 2010 at 4:50am

Edited: 31/08/2010 6:03am

yes I have submitted my site two dys ago using that link, and included GoogleSiteMap::enable_google_notification(); in php/_config.php, but still the website is not yet indexed.. is there anything else I can do?

btw, do I have to keep the google verification meta tag? bacause I removed it after verification is done..

thanks