Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

NEWSLETTER


Reply

7 Posts   792 Views

Avatar
servalman

31 July 2010 at 4:08am Community Member, 211 Posts

Hi

I was just wondering if someone has the newsletter module workin correctly.

I was able to install it but it is all buggy (I run 2.4) I know it is not suported but myabe someone can help :

My first bug is the the following when I create a new Newsletter type ans try to set the options I can't save anything and I get the folowing:

81: missing ; before statement <br /> <b>Fatal error</b>: Class 'Database' not found in <b>/var/www/vhosts/dominiquefiat.com/httpdocs/fiatwebdev/newsletter/code/NewsletterAdmin.php</b> on line <b>650</b><br />
(?)()

If anyone hed the same problem please help.

On the other hand if the module i really not workin what is the solution to have a newsletter function integrated in silverstripe

Thank for any suggestion

Avatar
Willr

31 July 2010 at 6:22pm Forum Moderator, 5511 Posts

Class 'Database' not found

Sounds like you don't have the correct version of Newsletter with SilverStripe. Make sure your versions are compatible (details on the newsletter page). If you do have the correctly matched versions try a /dev/build?flush=1.

Avatar
servalman

1 August 2010 at 2:46am Community Member, 211 Posts

Hi

Thank you for you response.

From what you say I should be able to make this newsletter module work ?

I needsome advice to install the right newsletter.

As I'm running 2.4 stable do I use 'newsletter-v0.4.0-rc1.tar.gz' ?

Then how shloud I proceed to make a clean install :

1) Remove the old Newsletter / run dev/build
2) install the new one run dev/build?flush=1 ?

Is that correct ?

Thank you

Avatar
servalman

1 August 2010 at 2:46am Community Member, 211 Posts

Hi

Thank you for you response.

From what you say I should be able to make this newsletter module work ?

I needsome advice to install the right newsletter.

As I'm running 2.4 stable do I use 'newsletter-v0.4.0-rc1.tar.gz' ?

Then how shloud I proceed to make a clean install :

1) Remove the old Newsletter / run dev/build
2) install the new one run dev/build?flush=1 ?

Is that correct ?

Thank you

Avatar
servalman

1 August 2010 at 11:03pm Community Member, 211 Posts

Hello

I just changed to the good version of newsletter and it seems to run smooth expept for one thing.

If someone has alrready submitted via the form and tries to submit again it seems that there is an error deleting the old subscription

any suggestion ?

Thanks again

NB: A function in the forum to delete a post or reply would be great

Avatar
Nobrainer Web

3 August 2010 at 7:51am Community Member, 135 Posts

Hi Servalman,

Just found this post - have issues with SS2.4 and the newsletter-v0.4.0-rc1.tar.gz. (Adding a subscription page causes errors, as described here: http://open.silverstripe.org/ticket/5605)

You write:
"I just changed to the good version of newsletter and it seems to run smooth expept for one thing."

Could you clearify good version? since it is not very usable as a reference for anyone.

Thank you

Avatar
servalman

3 August 2010 at 9:03pm Community Member, 211 Posts

Hi

I used the the same file that you used : newsletter-v0.4.0-rc1.tar.gz

Wich seems to work form me.

I have also one pb with subscrition :

When someone has alreday subscribed to the newsletter and if try to subscribe another time it deosn't supress the first subscription but throw an error

T