Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

YouTube Moldule


Reply


7 Posts   922 Views

Avatar
davidm2010

Community Member, 107 Posts

16 July 2010 at 2:36am

Can anyone tell me if the Youtube module is still being maintained? If so, can I get a link to the latest SVN site?

Thanks,

DM

Avatar
Willr

Forum Moderator, 5513 Posts

16 July 2010 at 10:01am

The latest copy of it is available from

http://svn.silverstripe.com/open/modules/youtubeservice/trunk

Its not been actively developed for a couple years now but I am happy to fix any issues / merge any patches that people want since it looks like I am the module maintainer :) I have no idea what state its in for 2.4.

Avatar
davidm2010

Community Member, 107 Posts

17 July 2010 at 8:43am

Well, good news on version 0.2, no errors. Bad news, it didn't even build. The module folder name is youtubeservice.

Avatar
Willr

Forum Moderator, 5513 Posts

17 July 2010 at 10:39am

Could you explain 'could not build'. Did you get an error message? If its in devmode and display_errors is on in your php.ini then hopefully you should get a much more detailed answer.

Avatar
davidm2010

Community Member, 107 Posts

17 July 2010 at 10:56am

I didn't have it in dev mode. I just added the folder and did a "http//.../dev/build?flush=1. It didn't build the database or add any new items, just returned as if nothing new was added. No error messages.

I did use this version (0.2) in 2.3 and it seemed to work fine.

DM

Avatar
davidm2010

Community Member, 107 Posts

21 July 2010 at 5:26am

Willr - I was able to install the Youtube. Not sure why it wasn't installing the last time.
DB build went perfect not one error or problem.
Created a youtube page - set it to do a search, Once again, worked flawlessly.
Went to the page, thumb nails and desciption, just as in earlier versions
Went to play in pop-up window recieved the following error:
Firefox did not play the video
IE 8 had the following:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322; yie8)
Timestamp: Tue, 20 Jul 2010 17:22:37 UTC

Message: 'Prototype.Browser.IE' is null or not an object
Line: 1003
Char: 3
Code: 0
URI: http://localhost/silverstripe/youtubeservice/javascript/lightwindow.js?m=1217201275

Message: 'null' is null or not an object
Line: 1578
Char: 4
Code: 0
URI: http://localhost/silverstripe/youtubeservice/javascript/lightwindow.js?m=1217201275

Thank You.

Avatar
Jeramie

Community Member, 34 Posts

21 December 2010 at 9:11am

Edited: 21/12/2010 9:27am

I successfully have the YouTube Module working on 2.4.3. Due to the change in location of some of the js files and the removal of the jsparty folder, you may need to tweak some previous "patches" as outlined here.

The YouTube module is calling the prototype.js file a second time and causing an issue. I circumvented this by

Adding these lines into the init() function of YouTubeGallery.php after line 116:

         Requirements::block("sapphire/javascript/prototype_improvements.js");
         Requirements::block("sapphire/thirdparty/prototype/prototype.js");
         Requirements::block("sapphire/thirdparty/behaviour/behaviour.js");

This allows the module to work both with the lightwindow and without.

*EDIT* Attaching the working module for whomever may need it.

Attached Files